Start a new topic

Android Beta 35

Hi all,


This should find its way to you via Google Play and a link from an email from HockeyApp if you have subscribed.


Not much to see different here. I'm fairly confident I've killed off another few bugs, and a few that I'm less sure of. Basically I'm still hunting down stability. So please keep submitting the crash reports - I am diligently working through them.


We weren't requesting the highest accuracy of GPS fixes from Android, so I think Google Services at times may have been throwing up less than perfect data. Strangely enough it can even obscure the data to protect your privacy, so even though the GPS may have a very accurate position, it may well move it before it passes it to OMN unless we set the right permissions.  I'm hoping this is the zig zagging that has been reported a few times resolved.


@Andrew - I'm expecting no change for you with this. I will be looking into that very soon.



You can download from here:

https://play.google.com/apps/testing/com.anquet.omn2


Many thanks,


Graham


Graham,

All maps now downloaded ok  by following your map repairing instructions.  This was done in Beta 34. Wonderful!  I’ve installed 35 using Hockey and it is looking good ( though as you know it still has find issue present) . Regarding install process I could see version 0.35 on Google Play when 0.34 was installed but  only   UNINSTALL  and OPEN buttons were presented to me, and not  UPDATE hence I went Hockey route.    Next time I’ll try OPEN since It occurs to me now that I didn’t try that.

 

A wish list subject:  I’d like to be able to view the publish date(s) and version(S) of any map(s)   I’m looking at on  screen be it from device storage or online.
regards
George

 

Hi Graham,

Installed Beta 0.35 over Beta 0.34 via hockeyapp without any problems.

White tiles
The white tiles noted in Beta 0.34 are also visible in Beta 0.35.

Tracklog test
I did a 2 hour walk and recorded a Tracklog using the default time
and distance recording parameters and used the device's GNSS receiver
only for location. I paused and resumed the tracklog recording once
during the walk. I checked the tracklog on PC-OMNB and it seemed
fine, certainly no zig-zagging. I did notice that some of the GE stats
seem to have disappeared e.g. ascent/descent and cumulative
ascent/descent, but that's on PC-OMNB.

Regards,
Paul Whitfield

 

Hi George I occasionally get uninstall/open in play.google even though the app is showing in the updates list. I just go back then in again and I see the update button. I've seen this with a number of apps and isn't specific to OMN.
Hi white tiles can still occur but they display after a restart of OMN and I've got streaming turned off. That is the tile exists on the SD. It is different tiles every time. Thanks
My first play with beta tracklogs. Did several tracks yesterday and today. Very mixed results. Firstly gpx editor does not work, it's greyed out, so I can't get back any saved tracks. Secondly I could not see how to get stats for part of a track. My first track test was initially by car, then some walking, then return by car. How do i get separate stats for these three segments? Initial reaction, not too user friendly yet.? Roger Hazlewood

Graham


Using 35 from Google Play Store.


I created a tracklog whilst driving this morning.  As with yesterdays test the tracklog from IpBike is smooth and follows the road.  The tracklog from OMN is again jagged.  The car odometer reports 17 miles (27 km), IpBike reports 27.2 and OMN 31.1km.  I have attached the OMNB tracklog (timed 9:11) Interestingly when you plot this on the map the points frequently only show either an East West movement or a North South movement. Looking further at the OMNB trackpoints they all show the final digit of the 12 digit grid ref as either a 0 or a 5.


I then used OMNB and OMNC to record a tracklog whilst walking.  The two tracklogs sit comfortably on top of each other except at the occasional change of direction where the corner cutting in the log is slightly different - accounted for by the timing of the recording of the trackpoints.  OMNB reports distance as 17.04km and OMNC reports distance as 17.8 km.  When I planned the route the distance was 16.5 km.   OMNB is set to record every 25 metres or 60 seconds whilst OMNC is set to record every 25 metres or 15 seconds (sorry I thought I had set them up the same).  Empirically I have found in the past, when walking, that it was necessary to set OMNC to record every 25 metres (with no time dependant features).  Most of the distance discrepancy between the planned route and both OMNB and OMNC are down to time dependant recording occurring when I had stopped.  e.g. OMNC recorded 0.9km whilst I was sat having lunch.  These tracklogs show a full range of the final digit of the 12 digit grid reference.  I have attached the OMNB GPX (timed 9:48).  When I stopped the tracklog on OMNB I got an OMN has stopped error but the tracklog was complete.


I have looked back at yesterday's cycle ride and again OMNB's trackpoints all end with either a 0 or 5 for the final digit of a 12 digit grid reference.  That was also recorded whilst running IpBike.


It points to OMNB misbehaving when IpBike is also asking for gps info.


David

gpx
gpx
Samsung a5 2017. Version 34. Installed okay via Google play. Did a reset. OMN didn't find the sd card where the maps are. The sd card was not in the list of available locations. Exited OMN and restarted. Still no sd card. All other apps work okay. Rebooted the phone and the sd card appeared. Move data. And all okay. I had the same issue once on version 29 or so. Version 35. Installed okay. Maps and sd card found okay. Note I did not do a reset. Problem. Cycling to work with a good GPS signal: The tracklog looks like a step function., not a smooth track! With all previous beta versions the tracklog has given me a smooth path that overlaid the route taken, maybe an odd spike from when inside a shop for a period. See attached file of the stepped track. On the train with a lousy GPS signal and tracklog running. The GPS position is well off track (typically about 1km off) and no data points are recorded. It only records a point when it gets a reasonably accurate position. Did another tracklog and this is smooth, so attached stepped track is odd. No crashes with 35 yet. Regards Nigel
Graham Downloaded from HockeyApp and installed over 34 (also from HockeyApp) Same as before; blue screen for 1 /2 sec with OMN stopped working message ASUS/settings/apps indicates v35 installed Andrew
Hi Graham The last few updates to 0MN Beta for Androids (now 35) have not worked. The programme will not start. I get a message saying 'Unfortunately Outdoor Map Navigator has stopped' I have to press OK. I have a Hudl2. In Settings Apps it shows it is present using 147 MB. Thanks Dennis
Went for a cracking walk today, 23k recorded on OMN. The tracklog accuracy looks good. OMN died at one point so report sent. What's happened to the grab handles when I want to edit a point?
I've got a track and a route open but can't close either. The gpx editor doesn't offer a close option.
Graham, A request for a feature or two. In GPX manager 1 close facility. You can open a track and delete a track, but you can't close a track. So you have to exit OMN to close it. Then you can delete it. 2 return to the same position in the GPX manager folder. At the moment you have to navigate through several layers to get back to the place you were. It would be much easier to use if OMN remembered where you were. Scaling of lines and points On the scaling issue of icons and lines I raised in an earlier beta. Whilst it behaves as you say, would it be possible to have another option which does a halfway scaling. The full scaling option makes them too big and obscures the map detail. At the moment the no scaling makes it hard to find waypoints or lines when zoomed in. This makes it hard to read when mounted on my handlebars in a phone case. GPX marker. Please can we have an option to set the line thickness. Again to make it easier to see at a distance and zoomed in. Line thickness Again a option to set the default line thickness would either appreciated. Please no crashes or unexpected closures on this beta so far. Thanks. Nigel
Getting exactly the same problem as Dennis Hills. Also on Tesco Hudl2 Steve.
Hi Graham, Installed via Google Play, same issue as others as regards offering the latest version. Perhaps a caching issue as refreshing the page offers the latest version. No problems here, but can I ask for the Save and Close functions in GPX editor to be separated? Then when you make a mistake you can recover easily! I know we have touched on version control before, but as a workaround how about implementing an Undo Sync function? Steve
Login to post a comment