Start a new topic

Android Beta 36

Hi all,

 

***PLEASE – open up My Maps and do a SYNC. Quite a lot has changed, and this should update everything.

 

Changes:

· Cultural bug where we would not start up on a device set to some foreign languages (Dutch was the example problem 0.5 vs 0,5 type thing.). Fixed.

· Grab Handles on Edit have been re-instated. Still some tidying up to do here on tolerances on selection.

· Find not working after moving maps to the SD card – fixed. You might need to move your maps back to internal and back to SD for this to get picked up.

· Trackpoint accuracy was getting messed up by being translated via the current map type. If you were on a course map type, with say each pixel being 25m, it meant each trackpoint got snapped to a 25m grid! It’s now getting parsed directly as it should not get snapped at all. Fixed. Many thanks to @David and his screenshots + I know a few others have helped with this one as well.

· Settings->GPS Markers & Tracklogs has a new checkbox – “Add the accuracy of the GPS fixing to trackpoint comment field.” Which gets correctly formatted to feet or metres.

· Can’t change map whilst map is centred on GPS location – fixed.

· Can’t use Find Place whilst map is locked to GPS – fixed.

· Some further crash report fixes to hopefully improve stability further.

· A lot of improvements to the background map download work. You should be able to set off large background map downloads now. I can now on my phone set say GroundRanger downloading and just leave it to work through all 10 maps whilst the phone is closed.

· Pause/Resume on downloads have been removed – I don’t think it was used much – cancel / download gets basically the same result. Some simplification to help with background downloads.

· Verify will now verify partial maps – it no longer fills in gaps, but just checks each map tile is the size expected IF we have it locally. If it’s wrong, it will download the replacement tile. This should therefore allow people to verify partial maps that with map streaming are now a common occurrence.

 

 

Next, I’m going to have a deeper dig to try to work out why we can no longer run up on some users devices.


You can download from here:

https://play.google.com/apps/testing/com.anquet.omn2

** this takes a little while to come out. HockeyApp email notifications will come out once the build completes.


Many thanks,


Graham


Hi Graham,

Installed Beta 0.36 over Beta 0.35 via hockeyapp without any problems.
Ran Synch in My Maps.

I tested the following and they all worked:
Grab Handles, Trackpoint accuracy (used OS GB Map),
GPS and Change Map, GPS and Find (including during
the recording of a track log).

White tiles
I removed  OS GB Map (the only map dataset that I had downloaded
in Beta 0.35). I then streamed all of OS GB Map and, partially, a number
of OS Road Map and OS 1:25K HD map datasets. The good news is that
I did not see any undrawn tiles when panning/zooming/changing maps.
The drawing in of tiles did seem a bit slower, not quite as smooth as Beta
0.35, but this was when the map was zoomed out. 

Verify
I performed a number of verifies on the partially downloaded map datasets
(OS Road Map, OS 1:25K HD) and they all seemed to work; though, after
one verify, the "My Maps" screen closed automatically and returned to the
"Change Map" screen.

Crash when enabling/disabling streaming
Between the streaming of the various map datasets to the Android device,
I used the Settings/Data streaming option to switch between Streaming enabled
and Streaming disabled. This caused Beta 0.36 to crash several times and a
crash report was generated each time (crash reports sent - four I think).

Regards,
Paul Whitfield

 

Been for a walk this morning with both S7 and Tab A. I think S7 said it had crashed on opening up, log sent, but it hadn't and the maps were displayed as normal. Walked just over 3km and everthing tracked prefectly, no rogue points. Could also change map with gps on and centred. Both devices worked well. Looking good.
Updated and did a sync on a poor internet connection. Sync said 'completed' but hung on the spinner. Force closed OMN and restart. All now seems ok Roger Hazlewood
Some thoughts on new features. I was recently out with a friend and showing them the new OMN maps and subscription model. Whilst very attracted to the new pricing for O/S maps, they had an issue with smartphone maps. They (like many others), need to 'orientated the map' to understand and visualise it.( They rotate their paper maps!) . I feel we need this option in the new 2017 OMN. It's present in several other apps. . A simple button to tap to give:- North up... Compass orientation ... Tracklogs direction... . (It would cycle through these). This 'compass option would be very useful as tool for novice users to identify distant hills or features. Just point your phone at it and there it is, on the phone centre line. Change map type to O/S road map for distant objects. When in 'compass mode' the gps marker would be moved to 3/4 down the screen, for more forward real estate, and a phone centre line graticule line would be on the screen. This would help even good map readers when the point of Interest is in the 'southern sector, ie back down your arm!. Once implemented this feature becomes the starting point to a 'full mountain navigation' feature. (More of this to follow). These two features would put OMN at the head of the pack. No one does this well at present. So whilst bug hunting must be a priority, let's think of new killer features. Roger Hazlewood
B35 updated automatically to B36 via Google Play. I think the issue of not offering the newest update is down to caching. If Play is only showing Uninstall and Open buttons, click on Read More then the back button and the latest version is offered. My first tracklog on 36 failed with a frozen app. Android showed the stopped working cancel/wait/report screen. BTW if we do send a Google report will you recieve it? The second attempt at a tracklog worked perfectly. Steve
Graham Used GP to update to 36. Tried to run sync over poorish internet. Sync never completed. Forced stop and restarted. Have used it on a walk to record tracklog and to plan a walk. All appears OK. David
Upgraded ok. Still getting white tiles as per my previous posts. Not sure how I'll sort out the gazetteer as I've too much on my SD card now. Ock well. Thanks

Hi chaps,

Looking at the submitted crash reports, the good news is this is looking a lot more stable. Certainly still some work to do on the crash reports, but I believe we have now got rid of the worst offenders which were creating the majority of the crashes.


@Paul – many thanks, and I will look into the enabling / disabling of wifi.


@Ian – many thanks.


@Roger – many thanks for doing the selling job for me

*** Copy and paste only pasted half my reply yesterday.


@Roger - I think I put a smiling face, and I think that is where the copy n paste stopped.  There are some great ideas being suggested at the moment, and I am rightly looking forward to the next set of development. It appears we are now finally close to having all of the basic foundations in place - four new apps, some shared logic code, servers that support it all, automated build servers so we can iterate and not least customers paying for subscriptions. Subscriptions are going very well - this is already changing the company.  I'm trying to keep my blinkers on at the moment, get Android out and get the last issues cleaned up. Route profile and further stats are next on the hit list, and then I think we need a data strip on the mobiles. Lots to do, but we are having good forward progress again now.


@Steve Lunn - many thanks.


@David - I've been thinking to keep a set of last 'good sync' files to fall back on in case we crash at just the wrong point.


@Steve James - hmm.  Can you do a Sync from My Maps, then verify the map you are getting white tiles on. Finally restart OMN, so that the cache is cleaned. Do you still get white tiles? Are they the same tiles, or they move? Do they finally fill in by themselves?


Thanks chaps,


Graham

Hello Graham,

I've just installed 0.36 from Hockey  and run a sync ok. I was hoping Google Play would give me an install option but it didn't.  The new version was present in the  GP BETA tab (since yesterday) and as last time the only buttons available were UNINSTALL & OPEN; the latter did  just open  0.35.    For information all other non beta apps update automatically.
As you suspected the Find still doesn't work, but moving my maps to internal and back again is not an option since it will swamp my internal memory and kill the phone. Have you a plan B please? preferably not one that entails deleting my maps even though I bet you'd like a fresh test of a new  bulk download of maps. This I will do if it helps however.

George

 

Downloaded beta 36 from the playstore and installed with no problems. With regard to bulk download testing, I have been trying to download the streetmap dataset since yesterday morning. It fell over at one stage (crash report sent). On some, but not all of the packages it has stopped at downloading the last few tiles and then moved onto the next one. Re-downloading the pages rapidly brought down the missing tiles. The download is very slow (it is currently bringing down SU) so any progress on sideloading would be welcome. Mike

Hi, yip done all that. I'm convinced that it is the reading of the tiles into the app rather than the wrong tiles/data.

I start OMN, pan around and get the occasional white tile. If I restart OMN then the white tile shows correctly. I've got streaming disabled just to prove that OMN cannot download the tile. It just fails to read and render the odd tile.


It's worse on 1:25kHD than on 1:50kHD.


Thanks

@George - I do have a plan B for the Find, but it will be in a further beta.


@Mike - so its basically been reliable, but hasn't always finished, and then you have had to re-download for it to finish? Whilst we stream from our servers in the UK, our downloads comes from servers in the US to keep costs down. However, please do keep in mind that downloading OS Streetview is over 20GB of map data if you are doing the complete country.


@Steve - strange. On the data front, I believe we do now have things pretty well tied down. I presume you are pulling data from the SD card? All I can think right now is if there is some sort of race condition as we load things in parallel, but as we open for read, we don't need file locks. Do you see it on say OS Road map or OS GB Map? Do you need to play with zoom to get this to happen, or just dragging the map is sufficient? Do you need to drag quickly and provoke it?

@George / @Steve - reading the code, I think the gazetteer might just work already as long as you have restarted OMN at somepoint. Can either of you confirm please?

Login to post a comment