Start a new topic

Android Beta 40

Hi all,


Google Play should when available now have a green icon.

Verify as @Paul pointed out, was in fact doing too much - it should now be quicker.

External on older devices was picking up android.omn when it should have had com.anquet.om2 in the path.

Some cleaning up on the Cancel button on My Maps and statuses.


You can download from:


HockeyApp: https://rink.hockeyapp.net/apps/b3133bdf93e04a62bcfc1612fccdec23


Google Play: https://play.google.com/apps/testing/com.anquet.omn2

** this takes a little while to come out. HockeyApp email notifications will come out once the build completes.



Graham


Graham


Upgraded to 40 from Google - the green icon is back.


David

Graham

Uninstalled v0.39; v.0.40 downloaded & installef from GP (18:10h) opened OK with Green Icon

Moved map data to external storage with /com.anquet.omn2/ path

Tried custom path to move to MicroSD card but failed. Path indicated as invalid

/com.anquet.omn2/ set up on MicroSD card but no test text file

Andrew


Hi Graham,


Downloaded and installed beta 0.40 from the Google store this morning.  Turned on the phones location services and opened OMN.  Map moves fine until I select the GPS location in the app.  I finally got the message 'app not responding" so quit.  Reopened the app and selected GPS location, again map freezes then when a location had been established the map moves.


Ernie


Hi Graham, my new SD arrived yesterday :-) 128Gb of raw storage......


  1. No SD in the slot I opened up OMN. It rightly reported that the location was missing and offered to start again internally. Good stuff.
  2. I downloaded the gazetteers and search worked well.
  3. I inserted the SD and moved the small dataset over to the SD. Search started misbehaving immediately.
  4. I tried on my Lenovo tablet and search works as expected no matter where the gazetteer is located.
  5. I tried on my old Moto G and again search misbehaves when the SD card is being used.

I've got a works Samsung so I'll try on that this evening, when I can get at an SD card.

Thanks

Hi Graham,

I've still to receive an email notification from hockeyapp for Beta 40.
The hockeyapp link in your opening post shows Beta 39 (2602), not
Beta 40. Has something got stuck in the pipeline?

Regards,
Paul Whitfield

 

@David – many thanks.


@Andrew – so pretty much as we expected, external is now working, but still no dice on the sd card. I will try for a further build with the permissions later.


@Steve – ahh a new SD Card.  Ok, so that’s some strange behaviour. My guess is this is probably the white tile issue as well, but one thing at a time. What springs to mind is storage size, as we search through the file by moving forward X bytes etc. But we should be abstracted from all of that.  Hmm.

The easy answer is to keep Find on internal, but that seems a bit heavy handed.


@Paul – you were quite right, I had one section of the build turned off, so I’ve pushed it through this am.

The other thing to consider is whether the gazetteer data is indexed. Your comment above suggests not ie if the search is Winchester do you start x bytes in? 

Have you considered putting the gazetteer sets in the database (or another database)?

Presumably you'd have many more options.


I had wondered whether keeping Find on internal but as you say it may also be the white tile issue.


Thanks Steve

Hi Graham,

Thanks. That seems to have cleared it. I now see the Beta 40 version on hockeyapp.

Quick question. Can verfies on map datasets be performed with Wifi OFF (I don't
have a SIM card, so no mobile Data either)?


Regards,
Paul Whitfield

 

S7edge 256gb SD. Updated off GP. everything seems ok. Gazetteers downloaded. Find is working. This now feels like a version I could use! Roger Hazlewood

@Steve - I did consider the move to sqlite this morning, but frankly that's large chunk of work - parsing data, sync, integration. Great to do, it would give other benefits, but a CHUNK of work that I really don't have space for at the moment. The code we are using here internally has been in use in OMN Classic and is therefore reliable, we have the download etc all working nicely. Let me dig, there might yet be an easy solution to this.


@Paul - I believe verify should work fine without wifi *IF* nothing is wrong, and it doesn't need to download any bad pkgs. Obviously if something is wrong, it will try to download the incorrect or updated pkg.


@Roger - excellent. Crash reports into our systems are now MUCH lower, so I think this is finally reaching a level of stability required. Hopefully a release is imminent, and then we can build in some more features.

Hi Graham,

Verifying map data
I performed the verifies with Wifi OFF.

The verifies were certainly less problematic than with Beta 0.39.
I verified all map datasests that were either Partial or Installed;
each map was verified individually.

For those verifies that ran long enough to sensibly display the
progress info (counters/percentage), the info is, unlike download
progress info, not displayed very smoothly and just seems to jump
in blocks which can give the impression that the verify process is a
bit "sticky". On the completion of a verify the screen can remain in
an unresponsive state for anything up to ~10 seconds and for the
fully installed OS 1:50K HD maps anything up to ~45 seconds.
 
The longest verifies were for the fully installed OS 1:50 K HD maps
which took approximately 4-5 minutes for each verify. For the two
fully installed maps, "Northern England" and  "Scottish Lowlands
 and Borders", I got the "OMN not responding" messages but there
were no crashes.

As a comparison, I ran a verify with Wifi ON for the OS 1:50K HD
map "Scottish Lowlands and Borders". This was much the same as
with Wifi OFF. The verify took ~7 minutes and the screen remained
unresponsive for ~60 seconds after completing with several
"OMN not responding" messages.

Regards,
Paul Whitfield

 

Downloaded v40, from gp, over v39 (with maps on the sd card). Downloaded 50k SD for the whole country, but several downloads still stopped at a few packes short of 100%. This seems to happen when two areas overlap slightly. Eg if Wales is loaded before Central England, the download for Wales stops around 99%, but a small amount of (missing?) data appears on the Central England). I too find the search unreliable as the gazetteer is on the sd card. Mike

@Steve, @Mike, @Andrew - do you mind looking at this build please:

https://support.anquet.com/discussions/topics/13000018055

Graham


Used beta 40 on a bike ride today.  For the first leg I started OMN and started tracklog, then started another application that also records gpx files.  When I stopped to consult the map I found that there was no tracklog visible on the map.  Looking at the recorded tracklog there is a Track and a segment record but no trackpoints.  The other apps tracklog is complete.


After lunch I started a new tracklog.  This one is complete and the track follows the route without any of the previous saw tooth errors.


David






Login to post a comment