Start a new topic

Android Beta 41

NOT FOR EVERYONE


You are welcome to install this, but unless you are having issues with Find on the SD Card, or SD Card permissions, this is likely a backward step.

I have therefore not released it via HockeyApp.  You can download it from:


https://anquetpublicdownloadcom.blob.core.windows.net/installations/android/com.anquet.omn2beta.apk


@Andrew - I'm hoping this has granted read and write access to the SD card, although I have to say on my device I got no warning or report of that - but different Android versions appear quite different.


@Steve / @Mike

If you can do a search for 'oxf'


You will get a set of popups:


These are cut from my PC, but my Nexus 6P and Galaxy S3 (internal and SD Card) gave the same results.

I am hoping you will get something different on your SD card and can tell me where....


some initial readings

image


An initial index for 'oxf'

image


some findings around oxf

image


Finally, some lookups. These may well be different - they are done in a parallel loop, and different OSs prioritise differently. I'm just popping up the first few results:


image


I look forward to your findings.


Graham




Hi, interesting....


I did exactly as asked and all values are the same (the place names different as expected) and the results display.


Here are some values for a search string that fails.

Search string - ches

results

aali 3105592, aaro 3105688, aaro 3105776

49534

7714812 7714906 7714996 7715095 7715192


Hopefully it'll be of some use...

Thanks Steve. I get exactly what you get there, but then I also get a box with 'Cheshunt field', etc.  I presume you get no results? Do you get the final box 'Results' ? I think I only display that if the function before returns at least 5 results. It looks like you have the right indexes, but the function that should turn them into strings is not returning. I'm going to remove the parallel loop and see if that helps.


Graham

Graham

Installed v0.41 OK

Moved data to external OK under /omn.anquet.omn2beta/

/com.anquet.omn2beta/ set up on SD card but no test text file

In custom entered drive path for SD card but returned as invalid path

Andrew



Hi Graham, I get the first 3 message boxes but not the 'results' one that displays the list of names.


Strangely enough I just tried again searching for 'ches' and it works fine (ie 4 message boxes then teh results display. I then tried 'win' and only get the first 3 message boxes, not the list of names message box nor do the results display.


Thanks

@Steve - would you mind giving this one a try please: 

https://anquetpublicdownloadcom.blob.core.windows.net/installations/android/com.anquet.omn2beta42.apk


I've removed the parallel loop. If that isn't the issue I will need to create another one with some more focussed debug messages.


Thanks,


Graham

Yippee, it's working. One thing I don't understand.... "I think I only display that if the function before returns at least 5 results" - if I enter full postcode the results popup shows multiple results 樂. The 'proper' results are correct.

Excellent.  One more crossed off my list.  The postcode issue makes sense to me, so no worries there - its a different structure that gets returned.


Thanks Steve.


Now to think on Andrews SD Card....


Graham

@Steve - I've been having a think about this, and its quite strange. Basically opening the file up multiple times but read only, and something on your phone is clashing. Yet it works reliably for others. I'm thinking the white tiles are the same issue. Did you see if you got white tiles whilst the data was on internal?


Anyway, a bit of a guess on this one, but having understood the issue on Find, I have now on load tile if we hit an issue, I back off for a random amount of time between 0 and 0.1 of a second, and will try again up to 10 times to load the tile, before sending back a null. My *guess* is we were at times getting the same sort of clash here we were getting on parallel load on Find. I can't put this into a single loop, as it will hit performance


I've also removed the the message boxes on Find. Finally I've put some re-try code in place on map download if a pkg doesn't get downloaded correctly. I guess I should beta this properly tomorrow, as it should be another step forward.


https://anquetpublicdownloadcom.blob.core.windows.net/installations/android/com.anquet.omn2beta43.apk


Many thanks,


Graham

Downloaded ver0.41 and got the exactly the same apart from the place names. After running 'find', I noticed that v0.41 pointed the map location was on the internal memory. I then moved the data to the sd card, and re-ran the 'find' with very different results. See screendumps.
Re last post, it was sent prematurely. I am not sure whether in v.41 the gazetteer was suposed to remain in the internal memory. When moving The location I noticed that 'SD CARD' was listed as a destination for the first time. Mike

Hi Graham, I tried this last night and wasn't able to get a white tile to appear. I'm only working on a small dataset as I have moved between SD and internal.


I did get a 'failing to respond' error and chose 'wait'. The app came back fairly quickly and I've not been able to repeat the whinge.


Thanks

@Mike - I'm about to release 44, and I think everything should be working there for you. If its not, please try Settings->Reset->Reset Find Place data.


@Steve - well lets see if this is the end of the white tiles or not - its consistent with the Find Place issue. Out of interest, you had some devices that Find worked fine on before the fix - have you seen white tiles on those?


@Andrew - I've not forgotten the sd card issue. Can I do a quick recap, to make sure I am clear on where we currently are:


You can now install fine from Google Play or HockeyApp - that issue is behind us.

You can now move data to External and everything runs ok - that issue is also behind us.

You can't get the SD Card to work.


If any of the above is wrong, please do correct me.


So regarding the SD Card:

If we can stick to the HockeyApp build for the moment - this is the easiest one for me to iterate builds on.

Settings->Data doesn't list SD Card.

You therefore tap on Custom.


1. If you then hide the keyboard, and tap on 'Search for Drives' - what results do you get please?

2. If you could then find the directory on the SD Card using a file manager and delete it. Then repeat step 1 - does it recreate the directory? I want to see if the current code creates that directory, or if it was an earlier build.


If you can confirm the above, and I will then build a further build with some more diagnostic information.


Many thanks,


Graham

Good point Graham, I've just checked on my Lenovo tablet where find works from the SD card. I've tried pretty hard and not been able to get a white tile to appear. Well done for persevering with the issue. Thanks
Login to post a comment