Start a new topic

Android Beta 44

Hi all,


This beta is really the bringing together of a number of little fixes.


- Find wasn't always working correctly when data was moved to the SD card - fixed.

- On Android 4.x devices, External wasn't being defined correctly for moving data - fixed.

- Improvements to Verify.

- Map Download improvements.

- Possible fix for some white tile issues.

- Auto-save.

- Changes to tracklogs.

- Keyboard now hidden when you return to Search results in Find.



Map download - quite a few people had reported it getting to say 98% and stopping. They then hit download and it would continue and finish. We had no re-try logic in place, so if any of the say 600 map tile downloads failed, they were just lost. Hitting download again would then download them. We now pause briefly and re-try the failed download a number of times. I sill have a few issues I wish to look at where connectivity is completely lost.


White tiles - it would appear that in doing the work on Find Place not always working on the sd card on some phones, that we found an issue around concurrently reading from the same file that some phones don't like. If a tile load now fails, it could be due to us reading a different tile at the same time, so again, we just try again a number of times.


Auto-Save - I have currently turned this off. This appeared to be causing issues not just in understanding, but also to the system. This will mean that the close and close and save buttons on GE now work correctly. It will also stop the lists in GM contracting by themselves.


Tracklogs - with auto-save gone, we now save the tracklog after each added trackpoint.



Regressions: we share a lot of screen code with iOS. For iOS 11 we have had to adopt an update of our list view component. We are working through a set of issues - GE now formats quite strangely - buttons are no longer right justified. My Maps - some arrows appear to loose knowing if they should be facing right or facing down. All of the issues I have seen so far are aesthetic, but there might be some further issues. We are working through this. I also think it might be a good time to re-think the GE interface a little to make room for statistics.



You can download from:


HockeyApp: https://rink.hockeyapp.net/apps/b3133bdf93e04a62bcfc1612fccdec23


Google Play: https://play.google.com/apps/testing/com.anquet.omn2

** this takes a little while to come out. HockeyApp email notifications will come out once the build completes.


Many thanks,


Graham




Graham, Downloaded v.44 from playstore and the 'find' problem seems to be solved. Thanks. I have not yet tried downloading. Mike
Downloaded from Hockey over Beta 40 all appears to work ok.
Changing maps, opening routes and using Find cause no problems.
When opening a route the waypoints are fine in RoadMap but are tiny in 50,000 HD, is there any way of enlarging them please?

 

Updated via Google play. Tried to zoom on 1:25000 map and app crashed. Crash log sent. Tried the app again with the same result. The process was start app, find place, zoom out. I tried it a 3rd time with a different place and I thought it was going to crash again but after about 30 seconds the new tiles downloaded.
Galaxy Tab2.7 Android 4.2.2
Tried zoom in and out on 1: 25000 maps without any problems, however mine are all on a SDcard so no downloads required.

Cliff

 

Another crash for me whilst recording a track log. Log sent. Had to revert to OMNC.... On S7 edge.
Hi Graham,

Installed Beta 0.44 over Beta 0.40 via hockeyapp without any
problems.

Stability
Although I didn't experience any crashes, Beta 0.44 doesn't seem
as stable beta 0.40. Several times, with start up showing the blue
screen, Beta 0.44 became unresponsive and I got the "OMN isn't
responding" message and had to quit. It always occured after the
previous session included verifying a map, but not every time.
Beta 0.44  always started OK after quitting from a "Not responding"
message.

Verifying map data
I performed some map data verifies with Wifi OFF.

The verifies are a lot quicker and smoother than Beta 0.40.
I did some tests with OS 1:50K HD. Verify times are, typically,
between 1 and 2 minutes. Sometimes, the counter would increment
by ~6%, at other times between 14% and 20% and seemed to slow
down as the verify progressed. On completion, there was still the
occasional unresponsiveness for a number of seconds which makes
it slightly irksome, but it is much better than Beta 0.40.

Regards,
Paul Whitfield

 

Hi Graham, Downloaded and installed OK. Opened, after blue screen delay, then everything looked good. Opened a previous route which was some miles away from my current map screen location and app froze. I got a not responding message, quit reopened repeated with the same route, route opened and located map on route, as expected. Still seems a bit hit and miss as too what is going to happen, Samsung Edge S7, running Samsung version 7.0 with security patch 1st August 2017. Ernie
Graham Tried to use 44 to record a tracklog whilst walking. Only 7 points over 2 minutes recorded. No other active apps. After starting tracklog turned screen off and put in pocket. When I looked 20 minutes later Android reported OMN not responding. David
Hi Graham, went for a walk today so decided to give the tracklog another go. I used the Garmin GLO today and made sure it had a good lock before opening OMN. The location app showed we had an accuracy of a few metres every time I looked and about 16/20 satilites with good signal strength. Tracklog set to 100 mtr distance. First attempt I managed to collect 3 points of track, I rebooted as the app was not responding and managed two when I looked a bit later. I switched off the Garmin and reset the phone to internal high accuracy location. Similar results a few track points recorded. I reset to network accuracy and managed to record a track to the end of the walk. Ernie
Looking good. Installed over 0.40.  Everything is working ok for me : maps installed on SD card; find now working & track log just plotted a 19 mile  rural motorcycle  ride ok.

 

Graham,
Bad news unfortunatly.
Galaxy Tab 2.7 Android 4.2.2
Used OMN to plot a route while in a vehicle. Continually crashed/froze after anything from 3 to 25 Mins of recording.. Sometimes a restart was possible but others required the Tab to be completely shut down and restarted. If a restart was necessary then settings had reverted to Internal and had to be reset to SD card.
Cliff

 

Graham Trying to verify 25kHD maps. On the phone it is taking ages. In the last 3 hours it has failed to complete the squares beginning with N. The counters do slowly increment. Speed check reports 70mbps download speed to phone. Doing the same on the PC is much faster and shows typical download speeds from your servers from 5 to occasional 11 Mbps. David
Graham
Took my Galaxy Note 3 and version .44 for a drive. Tracklog recording started and was working OK. I then tried ... settings...GPS Marker and Tracklog...shows the screen OK then try to adjust "every x metres" and the program hangs. First time had to reboot. Second and third times gave "not responding" and I sent report.

I know it is a 'silly' thing to do while recording, but that is beta testing! trying the silly stuff too :)

Roger P

 

Hi chaps,

 

Sorry, I’ve been tied up on the iOS side, but that has led to a lot of fixes in core code which will be arriving on Andoid very soon. In fact, there is quite a lot coming to the next Android beta – improved map download and verification work. My Maps, IM, GM and GE have an improved interface. Stats has now also been integrated into GE (work still in progress).

Anis is now starting work on some top of the screen display work, so we can start to report back things like current location etc


However, the iOS work has raised some good questions, which I would like the input from the Android users on.


Change Map and My Maps

In day-to-day use I feel that My Maps is of little use. It’s purely useful for downloading and removing mapping. “View Map” in My Maps takes you to the centre of a 100km square – that’s not really that useful.


When you hit Change Map, we get the location of the centre of the map. We then look through ALL maps on your account, subscription or otherwise to find out what other maps on your account cover this location. Please note, this has nothing to do with what mapping is actually on your device – we are simply compiling a list of maps that you have access to, that cover this location. We then present this list to the user.


When you tap on one of those items, we then look to see if its locally available – if so, great and we display it. If not, we see if you have steaming enabled, are we on wifi etc etc, and if everything is in place, we stream the mapping into place for you. Otherwise, you get tiles stating ‘streaming disabled’


This list is in fact very powerful – possibly too powerful at times, and for me it has real value as a user. With the advent of subscriptions, its power is possibly diminished, as most users will now all have 25k, 50k etc. Of course, users of say historic mapping would still find it useful.


A common question we get is when someone has 50k of all the country, and 25k for say the Lakes, and they ask why when over a location in Scotland, 25k is not listed. Well if it was, what would we do, just move the map to a random location in the Lakes?


Before Streaming, we only listed maps that were downloaded into the available maps. Therefore, logically you would look down the list, if nothing suited you, you got to the bottom of the list, and hit My Maps to see if you had something to download. This has now changed.


Why the above explanation?


For me personally, the Change Map menu does what it says on the label – you can Change Map with it. However, My Maps I don’t think belongs as the final option on the Change Map screen.


I therefore propose removing My Maps from Change Map, and otherwise leaving Change Map as it is.


Quite a lot of new users aren’t finding where to download maps. Where should My Maps be? On the main menu below Change Maps? At the bottom of the main menu? Should it now be called ‘Offline Maps’?


I think my favoured solution right now is keep it as My Maps and place it above Settings on the main menu. Others are suggesting putting it in Settings – I quite like this, as once setup, you won’t use it much, so why take up space on the main menu.


Your thoughts and input please.

 

@Mike – thanks.

@Ian – thanks.

@Cliff – you should be able to set a larger style on them. Long press on the route, select Styles->Waypoint Styles on Route and select one of the large options.

@Paul / @Ernie / @David – the next beta should make the whole download / verification process much more reliable, so please await that beta. A lot of core code changes.

@David – I will be back to the tracklog reliability issue very soon. Something still not quite right.

@Pendennis – nice to see someone getting a full tracklog out!

@Roger – we have something not quite stable in tracklogs, which I need to hunt down.

 

Thanks chaps,

 

Graham

 

Login to post a comment