Start a new topic

macOS Beta 48 - Statistics + other fixes

Hi all,


First of all apologies for it being around 2 months since the last beta.


This actually means that there will be a LOT of under the hood changes to this beta, as the majority of our code is shared across PC, macOS, iOS and Android. Therefore as we fix a logic bug for say Android, it goes into core code. Hopefully the majority of these changes are for the better and should make macOS better. Its also true to say, that we may well get a few regressions - in which case, please do just flag them up to me.


  • Right Click in GE Change Icon has been fixed.
  • GPX Editor was named GPX Explorer in a few places - fixed.
  • macOS Help is now named correctly.
  • Time column in GE now respects time zones correctly.
  • Preferences->GPX Editor now has a lot more options such as Estimated Time, Ascent, Descent, etc.
  • My Maps has had Pause/Resume removed to make it consistent with changes on the mobiles.


It can be downloaded from here:

https://rink.hockeyapp.net/apps/88c016c1271041c48c0c6f0825871c62


Many thanks,


Graham


Sorry to report trying to select waypoints in GE causes a crash, when I attempt to scroll down.  Crashing seems inconsistent.  I can select some waypoints, but unable to batch change icon.  Then when I move the  cursor it will crash.

Now when I open I'm getting a message: Disk Full Download failed due to insufficient storage.  Plenty storage.  After closing the pop up windows OMN seems ok.


Opened a couple of more times and no message.


On one crash when I reopened I got a duplicate of the file in GM  somehow.

Sorry Graham, still a crash when I do "Clear icon" on GPX editor too.


Also, I can't see how to name a waypoint in GPX editor, or is that something still to be added. There is a name column but I can't seem to add anything into it.

Hi Graham,


Downloaded and installed, I can not open the app.  It does sort of open but I get the rainbow wheel and not responding, force quit and sent a couple of reports.  I tried changing the firewall privacy to allow unauthorised apps and this made no difference.


Ernie

Hi Graham, I decided to reboot the Mac, something I usually do not need to do that often opened beta 0.48 same as previous post. Tried the privacy setting/firewall again, same result. The after a few minutes the OMN opened. Obviously I’d not left it long enough but there was no warning notices that anything was happening and as far as the Mac was concerned the app was not responding. Anyway it all is working fine now, opens fast, opened GPX Files and edited without problems. This might be a double post as I posted a similar comment earlier in the day but it does not seem to have been posted? Ernie

Hi Graham,

Downloaded and installed without any problems.  Opened very quickly almost instantaneously!

Editing of points in close proximity is greatly improved in fact I would say perfect.

Changed Waypoint Icon and Track Line Style in GPX Editor without any problems.

Not a very extensive trial but at first glance everything is looking good.


Peter

Hi Graham,


I've just install MacOS High Sierra 10.13.  Opened OMN took ages to load but once it's gone through that initial delayed start it opens quickly.  Everything looks like it's working OK.


Ernie

Hi Graham,


Opened My Maps, did a sync.  Then selected 1:25KHD and 11 tiles, clicked Verify and watched.  The process started so I left the machine to do it's thing.  Came back later and the verify had stopped.  I tired this a couple of times and ended up with two tiles nearly completed but the app locked. Only option I could select was Sync so I tried that and the sync never completed see attached screen images.


Ernie

Morning chaps,



So what surprises me the most here is, not one comment on the columns in GE which bring the new stats into play!



The GE is made up of a TreeView (left side) and a ListView (right side). I had found and fixed the bug of clicking on the route in TreeView and setting an icon for the complete route was crashing the system. 


However, it appears that you can also crash it by selecting icons in the ListView and trying to set the icon. 


Is there another scenario that I am missing? Is this right now the main gremlin?




@GrahamJH - Disk Full is an interesting one. Thats a new bit of code as we have hit that on mobiles, but why it should flag up falsely on macOS I don't know.


@Karl - I presume your crash is from the ListView and not from the TreeView, in which case its the bug I have hopefully identified above.


@Ernie - it appears we get a slow startup periodically, and it seems to happen after an OS or OMN software update, and once done, seems to be gone. Like you, I open in an instant right now, but I had an initial slow startup. Can you open up My Maps, and do a Sync. The verify issue may well resolve itself, or it might need a new release of code - there have been some changes around this recently.


@Peter - many thanks.



Many thanks chaps,


Graham


Hi Graham,


I'd already tried a map sync but repeated the process and set the Verify off on the !:25KHD maps.  I let it do it's thing then returned after about 30 mins and OMN was not responding, screen shot 1.

Force Quit and restarted the process and after a further 20 mins OMN was not responding, screen shot 2.

My Mac does sleep after about 15 mins but other apps happily download data updates etc. in the back ground.


Ernie

OK, lots of new stats available, very welcome.  Couple of points.  What are "estimated/cumulative estimated time"?  Can't quite figure it out from Time col.  Cumulative estimated time for today's bike ride shows 9 hours, when it was actually around 2 hours.  


Any poss of having "Moving Time", as I don't want to count "comfort breaks"?


I succeeded to select and change the icons for today's route, but when I try with my 5000 motorhome camping waypoints I just get a crash as soon as I try to change from "my waypoint style" to "icon".

Hi Graham No sorry my crash is still on Tree Ciew when I press clear icon not list view Also, do you know if you can name a waypoint as the name column is in the editor but I can’t seem to click it. Thanks.

Just realised, Estimated Time is Naismith!!

Hi Graham,

I had a very odd experience with GE.

I could only see 15 columns in GE though the Preferences show 26 and all seemed ticked by default.

I have a 27 inch screen and tried squeezing the columns but 15 seems to be my max. even when scrolling as far as I can.

If I tried to delete Comment or Description and OMN crashed. I tried this 3 times.

Trying to delete Hidden distance removed the tick but had no effect on the columns even if I closed and reopen GE.

I thought I would try a few more test and opened OMN for the fourth time.  Suddenly several ticks vanished.  I found I could delete Comment and Description with no problem.  In fact it all magically started working as expected.


Peter

Login to post a comment