Start a new topic

iOS Beta 1.03

Hi all,


This should come via HockeyApp, I will push to TestFlight if early testing here is good.


This beta is a lot about Map Download.


First off, let me say that iOS is very clever - complex, but also very clever.


iOS works hard to look after its users. If we are using up processing power in the background, it suspends us. If we want to do downloads in the background, we can't - we have to tell iOS what we want to download in the background, and iOS will handle it for us. That also means that iOS can decide to pause the downloads to preserve battery, or if the internet link is poor.


I think you get the picture - iOS rightly doesn't trust us with your battery or performance, or any other app! And frankly, that's a good thing for iOS users.



Prior to iOS 11, the above was true, but we had more wriggle room.


So what have we done?


On hitting download, we now create a queue of map tiles to download. We then submit a small set of those to iOS**. As iOS passes back the downloads, we queue new ones until our internal queue is empty.


** we did try submitting them all, but whilst iOS would allow us, it took AGES to queue them up.


Whilst we are a foreground process, we can insist on iOS downloading those tiles now. So if you leave OMN in the foreground, it will just chug through the downloads as expected.


However, if we are a background process or suspended when the set of tiles finish downloading, iOS wakes us up in the background, we process the tiles, and queue some more - but if we queue from the background, iOS controls WHEN the newly tiles will get downloaded, which is determined by battery level, wifi, blah blah. i.e. we loose control, so things can slow down or even stop. Bring OMN to the foreground, and it will all start moving again.


Within the confines of the current OMN data setup - 1000's of files, this seems to work well.



The other change is to the way My Maps works.

You no longer need to tap on the arrow to expand or contract a product - you can tap anywhere. Long press, and you get the menu. We are looking to take this way of working to GM and GE in the next few betas.


Currently you have to long press on a map to get the menu up - this I think is unnecessary, so I'm hoping this can move back to a simple tap.


The has been quite a lot work back in the foundations. I'm hoping this goes fairly easily, and we can move forward again on functions.



Graham




Hi Graham, Downloaded via Hockey and installed OK, however, it created a fresh install not installing over 1.02 so it did a complete log in, sync etc. I’m now resetting my preferences before testing. Ernie

@Ernie - that makes sense. HockeyApp will be a 'beta' and separate from what I will push to TestFlight. When I push to TestFlight, it will go through Apple vetting, and if good, I can then push that live.

Hi Graham, unable to use, set anything that has icons or styles, I just get a delete or rename option. Ernie
Hi Graham, Just seen your comment above, both my current app, via Tesfligt and Hockey have the green app icon. Ernie

I take it your 'unable to use' comment is regarding the Icon Manager? That needs fixing - its the update to iOS 11 tools -we know how to fix it.

Hi Graham, I’ve just tried to download a 1:25KHD tile TL and I get no options to download. I tried a map sync and after completion it still would not work. Not much appears to be working for me? IOS 11.0.2 Ernie

Ok, this beta is a little ugly. I thought just My Maps had been updated to the new ListView, so I tested that and let this out. Turns out, its in use in GE, GM and IM. I guess have a look at My Maps and download. We will get to work on cleaning this up.


Graham

Sorry, long pressworks and I’ve never seen it download so fast! Ernie

Ernie - you need to Long Press on the map. I'm getting that changed to a tap.

same as Ernie, change maps and selecting an area I don't get any option to view or download. Stuck with the default map...

Should have read the comments, long press works

got a black bar saying queueing tiles to download, selected map shows as downloading but no progress bar - all of this in foreground. suspect it isn't downloading... 

Dennis

@Dennis, same as you, initially I thought it had downloaded really fast but can now see it’s been stuck and still says partial on the same tile I tried to download. I can not get the maps to respond at all. No info or progress data. Ernie
I have initiated a large download which appears to continue in the background and keeps going when foregrounded. Will see how it gets on. For some reason though the 1.03 has no location services available and no option to turn it on as there is in the apps least for others (including 1.02). Never had a problem before and 1.02 continues to work as normal. Anyone know the answer ? Tim
Answer to the first question is that it stopped downloading with no info to tell me. Started it again and it picked up where it left off. Bit strange.....
Login to post a comment