Start a new topic

iOS Beta 1.03

Hi all,


This should come via HockeyApp, I will push to TestFlight if early testing here is good.


This beta is a lot about Map Download.


First off, let me say that iOS is very clever - complex, but also very clever.


iOS works hard to look after its users. If we are using up processing power in the background, it suspends us. If we want to do downloads in the background, we can't - we have to tell iOS what we want to download in the background, and iOS will handle it for us. That also means that iOS can decide to pause the downloads to preserve battery, or if the internet link is poor.


I think you get the picture - iOS rightly doesn't trust us with your battery or performance, or any other app! And frankly, that's a good thing for iOS users.



Prior to iOS 11, the above was true, but we had more wriggle room.


So what have we done?


On hitting download, we now create a queue of map tiles to download. We then submit a small set of those to iOS**. As iOS passes back the downloads, we queue new ones until our internal queue is empty.


** we did try submitting them all, but whilst iOS would allow us, it took AGES to queue them up.


Whilst we are a foreground process, we can insist on iOS downloading those tiles now. So if you leave OMN in the foreground, it will just chug through the downloads as expected.


However, if we are a background process or suspended when the set of tiles finish downloading, iOS wakes us up in the background, we process the tiles, and queue some more - but if we queue from the background, iOS controls WHEN the newly tiles will get downloaded, which is determined by battery level, wifi, blah blah. i.e. we loose control, so things can slow down or even stop. Bring OMN to the foreground, and it will all start moving again.


Within the confines of the current OMN data setup - 1000's of files, this seems to work well.



The other change is to the way My Maps works.

You no longer need to tap on the arrow to expand or contract a product - you can tap anywhere. Long press, and you get the menu. We are looking to take this way of working to GM and GE in the next few betas.


Currently you have to long press on a map to get the menu up - this I think is unnecessary, so I'm hoping this can move back to a simple tap.


The has been quite a lot work back in the foundations. I'm hoping this goes fairly easily, and we can move forward again on functions.



Graham




Hi Graham,


Much the same for me,


Downloaded ok - I ended up with both 1.01 and 1.03 which was surprising. I trashed 1.01 but 1.03 stalled on syncing icons - after 10mins I trashed it and installed again.


Try to change a GPS icon and the twisties in the IM don't open - all I get is rename and delete options..


Tried to download 2 map and noticed they downloaded in parallel - not sequential as before. Both stalled at 75% and failed to complete.


Opened GM tapped a route and nothing happened - ir it did not open onto a map. GM screen then frozen.


Tapped GPS button, map failed to centre and no marker appeared (although the button did change its status colours.


So I'm afraid to say that 1.03 just fails to work.


Tony

ok chaps, really not what I was expecting.....


Lets split this up. The interface issues - I didn't realise how widespread the new component`s interference was. I`m not overly concerned about that - its just work to get the code updated. We got a new component for iOS 11, and it needs a little bedding in.


However, I've been downloading large sets of maps without issue, and I've done a fair amount of testing with my iPad and the simulators. So the results here, a) aren't encouraging, and b) baffle me a little....


As I started writing this, I put 25k HD square ST to download, its currently at 21% and marching through nicely.


On hitting download, I got a small window up, which queues up the tiles. Shortly after that, the progress counter for the map starting moving. Its now at 27%.


@Dennis - when it states 'Downloading', it will have submitted the first tiles to iOS, but we wont mark progress until we get those back downloaded from iOS, at which point the map starts to download.


@Tim - Can you check your iOS notifications - if we are backgrounded, and iOS decides to close us, we pop a notification into the notifications. When you restart a download, it always works out what needs to be downloaded, and just downloads that.


@Tony - 1.01 will be the release, 1.03 the beta - they won't be sharing data. Synching icons, my guess is you have a LOT of duplicates, hence the time - this is high on my list to resolve. how long did you give the maps at 75%? They can at times take a while, depending on what iOS is doing?


I'm sorry to say I didn't even try the GPS - I wasn't aware changes had been made there, but something obviously isn't running.



Interface - this needs resolving, but I'm not overly concerned about that.

GPS - obviously needs resolving, and my guess is a small Android change has most likely caused an issue here.


Map Download - I'm just surprised at the results. I've just popped into My Maps now, an ST is happily at 82% and climbing....

Is anyone getting decent map downloading, or just me ?  Hmm.


Graham

my downloads have still not started. All of you who have had downloads work, have you updated to ios 11? I haven't yet upgraded, still running 10.3.3.

Dennis

Hi Graham, Attached is all I’m getting, no download at all. IOS 11.0.2 IPad Pro 10.5” Ernie

As I mentioned I'm still on ios 10.3.3 and the gps is working for me... it centres and shows marker..

streaming works but downloads (multiple now) don't.

I wasn't going to upgrade to ios 11 just yet as  I need to be able to run classic this coming weekend (for the compass... just in case). To be honest it is a major pain not having compass in OMN yet...

Dennis

Hi Graham, I repeated the map download again - 25k HD SU got to 1201/1600 (75%) as before and stalled. No movement after another 20min. So then tried ST (the one you mentioned). It got to 1499/1568 (96%) then stalled. Again no further movement after 20mins. All this was done in the foreground. Hope this helps. Trying times!! Tony
I am on 11.01 and have nearly 100 Gb free iPad Air The large download 50K HD SW region that I restarted eventually completed in the foreground albeit I had closed and reopened several times. I have had no iOS notifications of the earlier paused download. I tried a small download in the background which was complete when I reopened. However no notification of success. I tried smallish parallel downloads in the foreground and both completed without issue. Same interface problems as others on icon edit and no location services. So in summary on downloads, I had one glitch on a download which I simply restarted and all was well. Notifications seem to be not working. Tim

Notwithstanding all the problems with 1.03 which is after all a beta I think the biggest issue is sorting out the icons problem which is now affecting 1.01 - the release version.


I upgraded to iOS11 when it was first released and all was initially well. Two days ago I created another 2 icons, uploaded them to OMN via MacOS and tried to sync them (as I had always done under iOS10) to my iPad (now iOS11). Syncing failed as did all subsequent icon management.


For example tap settings>styles / icons and try to change the default WP icon, the IM screen appears but tapping one of the folders (e.g. markers) results in no response and a frozen screen. Tap Sync and OMN hangs. Not good on a release version given many will have upgraded to iOS11. I really do feel the icons issue (syncing, selecting, duplicates) does need fixing with some urgency. Then lets get to 1.03...


On a related point I now have both 1.01 and 1.03 on my iPad - both show a green strip so its a matter of guesswork which one to tap. Shouldn't the 1.03beta sport a red strip?


Tony


Graham,


Map download. I tried 25k HD map SU again still stuck at 1200/1600 (75%). I tried to remove the partial SU but on a long press all I get is view map - no remove! Seems you only get that option once the map is installed


With SU & ST stalled I then tried to install SW and SX and both downloaded fine. Not really wanting them I tried to remove them but all I got was 'pending' - maybe due to SU and ST still hanging. How then does one now remove a partially installed map? At the moment all I can do is trash 1.03 and reinstall it again which is a bit of sledgehammer approach I feel. All a bit messy.


Tony

@Tony, Reading Graham’s earlier post he seems to have a handle on the icon issue but I totally agree that the released version should be sorted urgently, that solution could then be easily and quickly ported to the next beta. The icon colours again need to be corrected, like you it’s confusing having two icons sitting next to each other which are identical. I’ve stuffed the realease icon/app into a map folder. A bigger concern for me is the range of experiences between different testers with map downloads with mine just struggling to download to completion any map using the map manager. Ernie

Hi chaps,


I'm preparing the next build....


@Dennis - the compass is getting up the list now, although certainly some other items ahead of it currently.


@Tony - the icon issue will be particular to your account - I will get on to that shortly. Whilst its in the release software, its a certain set of circumstances the make this occur, so its not affecting very many people. But it does need resolving.

Probably the best thing I can do right now is blank out the icons on your account on the database. I presume you have local copies of the icons you have created? Let me know, and I can do this - I don't want to do it until you give me the nod, otherwise you could loose data. 


Graham

Hi chaps,


1.04 is now up:

https://support.anquet.com/discussions/topics/13000018153


Many thanks,


Graham

Login to post a comment