Start a new topic

iOS Beta 1.04

Hi all,


This one is hopefully about fixing a lot of things from 1.03 that didn't work out.


Both the beta and live have the same icon, but we should have different names, with this being called 'OMN Beta' below the icon.


GPS - turns out iOS 11 added more privacy options, and we needed a little bit of new code to be put in place - hopefully this is back working again.


My Maps / GE / Icon Manager / GM - we have now implemented single tap to expand lists, and long tap for the menu when required. I have some further changes in planned for GE.


Map Download - lots of feedback, and lots of different issues.  Call this Take 2.


I look forward to your comments.


Graham


installed 1.04 on iphone. 1:25K HD download of SU. progressing very well. got to 1017/1600. pressed button at side of phone to put phone to sleep. reopened phone. download appears stuck at 1017/1600. left it for 5mins or so (not moved) and closed phone again. on reopening download came back to life.. got to 1438/1600, closed phone again and reopened . download restarted after about 2 mins. continued until 1531/1600 (96%) and now appears stuck. closing phone and reopening doesn't shift it..

Dennis

Couldn't get the download to move so hit cancel and then attempted download again. the map completed download but on the way it reported oddly. One second it was at 390 (25%) next moment at 96% then back to 32% , ie jumping all over the place. 

Would it be better experience under ios 11?

Dennis

Hi Graham, Downloaded and installed OK. This beta looks to be much more stable and all the things I’ve managed to test look to be functioning correctly. I can select icon etc. And I’ve downloaded the TL 1:25KHD tiles without any problems. I did a GPX manager sync which did hang but restarting the app and retrying it all went through OK. So far looking all good for me. Ernie

Hi Graham, 

I tried downloading 1:25K HD ST, this time in foreground.  download is no longer linear. There appeared to be 2 different displays showing,  like 356 /1568 (24%) and 1439/1569 (98%) so the %age no longer gives an meaningful idea of how a download is progressing. ST appears to have completely downloaded but my maps is still showing "downloading" not "installed". 

Dennis

Hi Graham - like Ernie, seems to be back on track. Map download is fine, icon use ok and gps works. Sync in GM or IM takes a very long time (@ernie, try just leaving it to see if it completes, takes several minutes). Could this time be anything to do with the duplication of icons that is still occurring I wonder? Good work Graham.~ I guess you are now freed up to get back to the compass work (just jesting you understand). Tony
Graham, a correction + icons do not appear to be duplicating on an IM sync although tgecsyn does take a very long time. So did you fix the duplication? Tony

Hi Graham,

Having read Tony's and Ernie's posts regarding successful downloads I just upgraded my phone to ios 11.0.3. Just downloaded 1:25K SS with no issues, it was sequential, it completed and showed installed as soon as it completed. Just tried gps, works fine. Find place, entered "ear" and selected entry for Earle Whin and it gives LAT/LON to 13/14 decimal places, too accurate for me!

Otherwise fine so far so it looks like my previous issues were probably due to ios 10.3.3

Ipad still on 10.3.3 though..

Dennis

Since I've lost the ability to run OMNC I am attempting to download a full set of GB 50K so I went to my maps, long press on 1:50K and hit download. every map shows "downloading" but I didn't get the black bar adding anything and nothing appears to be downloading. 1 map, scottish lowlands and borders shows in a different font, see attached.(haven't got the knack of getting perfect screen shots yet.. )

Is this meant to work yet?

Dennis

IMG1142.PNG
(125 KB)
Sad to say download behaviour is very erratic. I have seen all of the issues noted by others and I have also had ‘clean’ downloads. Backgrounding while downloading just seems to freeze the download, sometimes it in sticks sometimes it does not. Still no notifications. Selecting multiple downloads seems to really cause problems. Omn crashed during an attempt a backgrounding this morning and you should have a crash report. On the good side location services are back with us. I am on 11.0.2 btw. Not looking stable enough to release to me. Tim

Hi Graham,

An update to my attempt to download the whole of 1:50K SD maps.Now running 11.0.3 on iphone.

 Although nothing appeared to be happening the phone was getting hot so I left it backgrounded to see what happened overnight. This morning, each of the components had started to download and each shows about 10% downloaded but omn had crashed during the night. In fact there were 2 events in analytics data. The first at 23:23:33 and the second at 23:28:33 (CPU time allowance exhausted). Hopefully you have the crashes.

Now it was the fact that all segments had partially completed that surprised me. I had expected the downloads to be queued in some way per your mail announcing 1.03.

Dennis

And another observation is that the list view following long press on a download is also variable in content ie sometimes you get just view sometimes the full list including remove. Not sure how it should behave but when the download has stalled it prevents you removing it. Seems to be a recurring issue with scheduling multiple downloads and I can not get anything to happen in background. Tim

@Dennis & Graham,


Dennis - I tried your GB 50K download with much the same results. The black panel did not show but the maps within the folder did start to download but with very odd results. Central England and Central Scotland showed installed but when others started to download those two then showed partial. Is this the download monitor playing up or what? Eventually all downloading stalled. Screen shot attached.


Tony

MyMaps.jpeg
(539 KB)

Graham,


I thought icons was now working but its not. I reset icons on the iPad and sync. After a bout 2 mins it completes. I can sync again and no duplicates appear. (That I thought indicated it was working). So then I went to MacOS and reset the icons (with the intension of re-uploading my custom one) and sync the colour wheel spins and I have to force quit. Is this to do with the icons in my account? If so could you do what you suggested - I have copies of my custom icons.


PS - I am still getting copies of my file names with '&' when I do a clean install.


Thanks for you help.


Tony

Graham, further to my previous mail - am I right in saying that a GM sync also automatically does an IM sync? and one further piece of info, an IM sync on MacOS (b48) results in duplicated icons plus trying to open a route in GM gives the coloured wheel and I have to force quit. Hopefully all to do with the icons file in my account.


Tony

Login to post a comment