Start a new topic

PC Beta 1.0.26

Hi all,

 

Quite a few changes in this one.


· New stats panel in GPX Editor screen

· Change Maps menu now lists maps of different map datums – which in English means that if you are on the South Coast, you will see French maps listed, and if you are on the North Coast of France you will see UK maps listed.

· Changes to core code in My Maps for download and verify – a lot of cleaning up post some fixes for the mobiles.

 

It should auto-update, or you can download from here:

https://rink.hockeyapp.net/apps/b781e300ff16447a868c8d8e78045d27

 

Many thanks,

 

Graham


image




Paul, Graham,

Seems I spoke too soon. When I tried to selevct a UK map, the only map listed was the French overview and MyMaps. I could not find a way to get the UK maps back so shut down OMNbeta. On restarting the French map was the only one available and then the whole thing froze. I the only way I could close it was in Task Manager. After this when trying to restartthe initial logo flicke onto the screen and then disappeared.

Deteting the beta files in C:\Users\<username>\AppData\Roaming\Outdoor Map Navigator, as suggested by Graham in the 25 beta thread restored OMNBeta to normal. I have not tried to view a French map since.

Mike.


 

Hi Graham,


GPX Import - French Map Workaround


I have now managed to successfully import the Garmin GPX file into OMNB.

I did this by using GPS Visualiser to strip out the waypoints.


The routes now come in as Tracks


Track syncs to my phone and is now almost perfect for what I need.

(Not having the Place/road names is a slight hindrance, but I have fix for that as well - see below)


I have tried other French routes and all worked once WPs removed.



Testing Included

  • Importing into a Surface Pro 4 with W10 - Failed
  • Booting into Safe mode with networking on one PC, j- Failed
  • Importing into OMN Classic  - Success - This is how I can get the place names



Tested importing lots of Garmin UK routes, deleting, syncing to phone etc. All worked fine


Regards

Paul

@MIke


Yes, that was the pickle I got into when first stared testing this import.

Glad your back up and running.


Thanks again for test

Paul


Hi all.

 

@Roger – thank-you.


@Ian – glad OS Street View is back running correctly.


@PaulQ – I am currently somewhat perplexed. Are your computers set to UK locale, or do you have them setup for French?


Can you try the following:

1. Settings->GPX Files – turn on Local File Management

2. Open up GE, and use the 3rd button from the left ‘open GPX file’

Does that work to open your file? I’m wondering if this is about an issue on import to our internal database, more than the actual fact the file is of French data. If that works, try renaming the GPX file and see if that imports as you were trying. In which case that would give me a good idea of where the issue is.

The fact you have it bad on lots of devices points to it being a bad import, that is now being replicated across devices by our sync tech.


@Paul – thanks for the typo, I will get that fixed. I tend to agree with you on the waypoint/trackpoint. It also causes the flickering, which is due to the fact that there is a mouse position between rows on the grid when neither above or below the mouse is highlighted, therefore it pings back to the last highlighted item which was the treeview item.


@Mike – there is not currently a way to copy the data out, but Export in general is on my to-do list. “When I tried to selevct a UK map, the only map listed was the French overview and MyMaps.” – most likely you had changed to a French map, and then moved further into France? The change map menu simply takes the centre of the map, and then lists any maps that you have access to at that location. If you are centred on Paris, there will be no OS 1:25,000 mapping. The freeze is obviously a bug, but I am hoping the other issues was a misunderstanding, however this is currently an issue, as you are not alone with this.


@Bill – thanks.


@David – many thanks, and a list of bugs for my list. Do you mind uploading the gpx file? My test files display ok, although looking at your screenshot, I’m guessing the empty Track name is most likely the issue, so most likely I can fabricate a test file.


@Ian / @RogerM – I had been thinking likewise, and have added that to my list.


Thanks chaps,

Graham

 

I seem to be able to switch between IGN & OS quite happily.
Win 10, desktop PC

 

Hi chaps,


The next one is up:

https://support.anquet.com/discussions/topics/13000018263


Graham

Hi Graham

All PC's  set to UK in Regional Settings


Tried your suggestions and at first thought you had cracked it, as the first two I tried worked.

I then tried the original file and still get same problem


I have since tried all sorts of combinations of routes in Basecamp, with a direct import to OMNB to eliminate any sync issues. 


Its a weird one alright, as the fact that two worked, but I could not get others with similar properties to work, has me stumped.


I'll put this one on the back burner - I can achieve what I need with a few workarounds, and it's only me that seems to have the problem and not too many people will be exporting from BaseCamp to OMNB


Hi Paul,


Its good to have a dig to see what the problem is, but as you say if we cant reliably reproduce the issue, I normally find its best to leave it for a while. Either it goes away, or we find it crops up with someone else, and that gives us more information to dig with.


Thanks for understanding.


Graham

Login to post a comment