Start a new topic

Startup Issue

Andy, I have moved this to a clean thread.


"

Posting this here as requested by yourselves in response to feedback I left via Google Play Store. : 
Nothing has changed since I emailed you a few months ago (17th August). This app just doesn't work on my Moto G4 Plus / Android 7.0 / 32GB+64GB SD card. It launches, but as before, if you go to menu / Maps at Current Location the list of available maps appears on a 'greyed out' screen. No input is accepted and the only way to get out of that frozen screen is to list open apps and close it there. Incidentally the same also happens if you go to Manage Maps - the screen freezes. I have never been able to get past this, so my premium subscription is useless to me for mobile mapping. Fortunately I still have the original OMN Classic on the phone (with its downloaded 1:50K mapping) and that still works.

When I wrote to you in August I was seeking a refund but was persuaded to persevere in the hope that the issue would be resolved during the development process - any news on that?

"


Whilst you can write lots to us on Google, they only give us 350 characters to reply with. It does make having a conversation a kind of an art form.


First of all, I am sorry that this hasn't been looked at earlier, but as you can probably imagine we had a lot of balls in the air back in August.


At the moment, I am only aware of a few people who can't run up at all, and they are all on I believe 4.x versions of Android. This is something that is on my near term list to investigate.


However, I don't believe that applies to you - a) you are on Android 7, and b) you are getting the software to run up, just not functioning as it should be.


Could I please ask you to do the following initially:


1. It appears the software runs up, so please open up Settings->About and check you are running 0.53.

2. Open up Settings->Reset and hit the top button. OMN will close.

3. On restarting, you will need to login. It should then go through a full sync telling you what it is doing as it goes. Does it get as far as 'Sync Finished' ?

4. If it does reach Sync Finished, then it should start to populate a map onto the screen.


If you can let me know how that goes, and we can progress from there.


Many thanks,


Graham



Thanks Graham, I've done that. Definitely 0.53. Sequence occurred as you suggested, Sync Find displayed as you said. When restarted I got a road map centered on (?) the Lake District, plus the location icon and the menu icon. Neither of those icons responded to touch (I waited 5 mins to make sure it wasn't initialising or something). Eventually I stopped the app from the OS and restarted it. This time the menu icon was responsive so I clicked on Maps at This Location. A list of my maps appeared but as before on a greyed and frozen (unresponsive) screen. Screenshot attached. Cheers, Andy

Thanks Andy for the quick response.


Certainly strange. Ok, so its the right software, sync has gone through fine, and in fact you are seeing a map. We default to the Lakes as we have some demo maps in that area.  So far so good.


The buttons however, should have worked, a couple of seconds delay might have been required, but not five minutes. Was this screen with the map on also grey? Could you move the map with your finger?


Graham

The map screen looks and behaves as I imagine it should - full colour, smoothly scrollable in all directions by touch, and two-finger zoomable. The map squares fill in quite rapidly when you scroll too. Odd isn't it? I did mention something in an earlier email which I thought might potentially cause problems, though may be irrelevant - I elected to have the OS treat inbuilt RAM and SD memory as though it was all contiguous. I can't switch that off without causing problems with everything I've installed to-date so can't experiment. I still have OMN Classic installed and functional - presumably that shouldn't clash? I'm reluctant to uninstall it as I use it very regularly.

Hi Andy, 


One of my colleagues thinks he may know the answer to this one. I'm hoping for a further beta today, but that might not transpire, but he is hopeful he might have a solution for this.


I will let you know when its available.


OMNC will not clash with OMN.


Many thanks,


Graham


Hi Andy,


Beta 54 has just been released. It normally takes a little while to hit Google Play.


https://support.anquet.com/discussions/topics/13000018631


If you can let me know if that solves this issue or not please.  Many thanks,


Graham

@Andy - it appears you replied to a support ticket, and the support desk didn't know about this issue, as this is on the beta forum.


I quote your reply here to keep things in the same place


"

Hi Graham


Sadly things are worse, not better.


After updating to Beta 54 the situation is as follows :

1) The opening screen now shows a map centred on my location rather than Lakes.

2) There are now two menu icons T/L & B/R plus the location icon.

3) This screen is totally unresponsive - touching icons doesn't do anything, map doesn't scroll or zoom, and the phones back-button (icon) is also unresponsive.


Am I literally the only person with this issue? Seems hard to believe and doesn't give me much hope of a solution. My phone is less than a year old and working perfectly with other apps.

Cheers, Andy

"


So not the result we were hoping for. The extra button makes sense, that's new work. I will have a further chat with the engineer on this one and revert to you.


I certainly have't given up on this - I only got my teeth into it a few days ago, and I've been sat waiting for feedback on this forum thread for the last two days.


Currently you are the only reported case of this issue I am aware of. That certainly doesn't mean that you will be the only case. I would certainly like to dig a bit further before putting this one on hold and seeing if anyone else has this issue.



Graham

That's strange, I have an unbroken sequence of emails originating with your reply to my initial post on this forum. I'm not sure where the support ticket part came in, I just replied to your emails as and when they came assuming our conversation was synced to the forum.

Anyway, glad to hear you haven't given up on this! My frustration is partly because I've been a fan of the product in its previous incarnations, but since subscribing over three months ago have been unable to use the subscription maps whilst out walking etc. As this appears to be a unique problem Its a pity you can't get your hands on a Moto G4 Plus and see for yourselves what's (not!) happening - or possibly find everything is fine at which point I'd have to accept that my phone is somehow at fault.

Andy


Hi Andy,


I've not done any dedicated work on this issue, but Beta 56 which has just gone live now has a LOT of changes to Android lifecycle work. Its possible that this might improve things, or it might not, but your feedback would be much appreciated.


I'm hoping to tie off a few more loose ends in Android, and then turn my attention properly to the remaining start-up issues that we have.


Beta 56:

https://support.anquet.com/discussions/topics/13000018747


Thank-you for your patience.


Graham



Thanks Graham, as soon as I get an update I'll let you know.
Cheers, Andy


OK, slight change, but its still locking up. The initial (startup) local map remains scroll-able (and zoomable) as before. Touching the location icon centres the map on my current location. Both menus are now responsive to clicks. The Top/L Menu icon causes a grey panel to appear at the top of the screen, divided into three sections. No text, just the panels. The Lower/R menu icon gives a menu with 9 entries (+ Cancel). Selecting 'Manage Maps at Current Location" or "Manage Maps" both (still) give greyed out screens on which items do not respond to touch selection. Manage Maps includes a SYNC button (also unresponsive). As before the system 'Back' icon is unresponsive, though the 'Home' and 'List running Apps' icons do respond.

Morning Andy,


Many thanks for the feedback.

The grey pullout is correct, if you double tap, you have a small selection of stats. You can swipe it up to contract it.  This is still very much a work in progress.


I've taken a quick look at the code based on your feedback, and I can see some differences between certain windows. Out of interest, does the 'Find' window work? Likewise Settings and GPX Manager and GPX Editor? I ask as they are constructed slightly differently to Maps at Location and Manage Maps which I believe are the only TWO windows which you can't interact with?


Many thanks,


Graham

Hi Graham,
Just had a more systematic look at what works and what doesn't:
The grey pullout behaves exactly as you said. Can swipe down to expand, display 'stats' text in grid squares.

MENU

Maps at Current Loc : (FREEZES)

Find : (OK) Tried postcode search & place name search, both gave valid looking info - neither shifted map focus to new location (?)

Start Tracklog : (OK) Got options to Pause & Stop - both of which appeared to function.
GPX Manager : (OK) My Routes and My Tracklogs dropdowns functioned.
GPX Editor : (OK) Date, Track, Segment dropdowns + INFO.
Edit Mode : (OK) Toggles ON/OFF - not sure what else this should do.
Settings : (OK) Lots of options shown, and sub-menus accessible.
Manage Maps : (FREEZES)

Actually quite encouraging, I hadn't explored much beyond the frozen screens for obvious reasons.
Hope this helps,
Thanks, Andy

Thanks Andy,


I hope to get onto this properly fairly soon. Find should have moved the map. Edit Mode will allow you to tap on waypoints on the screen and then move them, turning it off (default) means you don't move data by accident. 


Silly question, the map that displays on the screen - can you scroll and zoom it with pinch?


So basically, its the two maps windows, and Find not actually doing anything.


Graham

Hi Graham
Thanks for quick response. Based on your explanation Edit mode appears to function fine - I can confirm a long press on the map and release brings up menu with options to 'Add Waypoint' or 'Start Route'. I was just tapping yesterday so didn't see this. And yes, the base map responds very smoothly to pinch-zoom and scrolling (at home on Wifi anyway). And apologies, on checking FIND again today it snaps the base map to the search result perfectly well. I tried several places yesterday without success, but its been 100% ok today with searches for various locations around the UK. So yes, still just the two map screens freezing every time I bring them up. Fingers crossed its something straightforward! I hadn't explored other menu options before because without map access there didn't seem much point, but good to see its probably a lot closer to working than I had feared.
Cheers, Andy

Login to post a comment