Start a new topic

Android Beta 56

Hi all,


Quite a few loose ends in this one, but also hopefully some good forward progress.


  • The statistics calculations have been re-worked - these were causing some of the crashes inside GE.
  • More lifecycle work for Android.
  • Startup - its likely to be slightly slower. I will come back to this. It would appear that the map was being presented to the user *before* some background tasks were finishing, and this had been leading to ANR's on users interacting before things were in fact fully ready.
  • Back key exiting I believe is now fixed.

Overall, I'm hoping this should for tracklogs be much more stable on coming back from being closed in the background by Android.

The stats bar has moved forward considerably, but is certainly not finished - plenty of loose ends here still.
  • It now just expands to fill part of the screen, and leaves the map showing.
  • Grid Reference and Time now update - but the update is not very smooth yet.
  • The information bar has currently been moved to be above the buttons at the bottom. It needs some more work, but was plainly wrong being above the stats bar.



You can download from:


HockeyApp: https://rink.hockeyapp.net/apps/b3133bdf93e04a62bcfc1612fccdec23


Google Play: https://play.google.com/apps/testing/com.anquet.omn2

** this takes a little while to come out. HockeyApp email notifications will come out once the build completes.


Enjoy the weekend,


Graham


Graham Have tried 56 with stopping and starting tracklogs and looking at info bar. 55 gave me lots of ANR but 56 was OK. I have had one ANR, feedback sent by Google. I was indoors and tried to get a GPS fix and then went to settings I think before I had a good fix. The swiping gestures for the status bar look OK. The only field that gets populated is the grid ref. Is this as expected at the moment? I find that the info bar now down towards the lower part of the screen is difficult to read when the map is an urban area. There is too much transparency. However once the stats are working at the top of the map I suspect that I would rarely use the info bar. David
Hi Graham,

Installed Beta 0.56 over Beta 0.55 via hockeyapp without any
problems.

Tracklog test
Consistent ANRs. Same one-hour walk as Beta 54 and Beta 55.
Tracklog recording parameters 10m/30s. I turned the display off at
the start and only turned it on to check the tracklog recording during
and at the end of the walk. I recorded the walk as a single tracklog file
with a single segment. The display was turned off for periods varying
between 10 and 20 minutes.

Each time I turned on the display to check the tracklog recording,
the OMN screen was frozen with the map centred at the location
where I had previously turned the display off. Each time, I then got
an ANR message and quit OMN. On recovery, OMN automatically
picked up the tracklog recording and the trackpoints were displayed.
As with Beta 55, if the OMN screen is frozen when the display is turned
on then tracklog recording ceases; as seen when I inadvertently turned
the display on which resulted in a gap (loss of trackpoint data) between
the screen being turned on and me noticing it.

Regards,
Paul Whitfield

 

Hi Just set tracklog going at start of car journey from Edinburgh to the lakes, then put phone away in my pocket. At destination, pull down said ?recording?. BUT app frozen. Recent apps did not revive it. Nor did reopen the OMN app. Only close all and then restart OMN worked. This showed tracklog was still recording. So track closed. Track had 5700 pts. 2hrs 30mins Image showed tracklog good till about the last 15 mins,(see image). Note that the tracklog went into areas where I had no existing downloaded tiles.
The eagle eyed amongst you will note that the crash was caused by crossing the lakes national park boundary! So should be easy to program a fix ?!? Just pay the fees! Roger
Run a track log yesterday on both my s7 and Tab A. The S7 got an ANR message so I sent the log. I forgot the Tab A was still running so after more than 12 hours and 130 miles I looked at it and the white screen with the track log appeared. I could move and zoom the track but no map appeared so I just left it. After a while the map appeared very slowly, I tried to move the map and got a ANR message so rather than send log I hit wait and shortly after the map moved. I could change the map, move it, zoom about but everything was very very slow.
Loaded 56 over 55 with no problems. Went for a short walk and the traclog worked fine, but the stats bar displayed just blank grey boxes: no numbers or labels. Screenshot attached. Mike
Hi mjp, try a double tap or long press on the grey stats boxes. You then get a (limited) user choice as to what stat you want in the box. This then auto updates . Looks like currently work in progress, but works for me. Roger Hazlewood
Roger, Thank very much. It worked fo me too. I have tried the back key exiting ( a problem I was having) and it is now ok. Mike
Upgraded fine. Used it a couple of times on a bike ride yesterday but didn't have enough juice to record a tracklog. I even found a new open water swimming place. Got the gpx from a mate so ran it through Lockito today whilst watching YouTube videos (no cat in sight). It worked very well.
Graham
Installed over 55, via hocky, without any problems.
Static test seems ok. Dynanic check tomorrow.
Cliff.
PS Any advance on the Black Input boxes yet. (Tab2.7 android 4.2.2) Have tried on a Galaxy A5 android 6.0.1 and the input boxes are totaly different and all user inputs are visible.

 

Another test this afternoon, with phone left in my pocket. App frozen on inspection, white screen which showed track but no map. Managed to get to menu screen to try to stop track, but then app froze ANR. report sent at 16.45. rogerh

Hi Graham,


Installed from GP with no problems.


Stat panel only showing GR and time.


Tried two track logs - One short mile long walk and another 8 mile drive. Both worked well.


Had a crash when closing a route in GE. Report sent.


Tried some route syncing and plotting. All fine.


Regards

Paul

Graham Friday with B54 Stated B54 and map was on screen immediately so must have been in background. Started tracklog. At end 15k 5:30 map flashed on screen & crashed to home screen. Restarted couldn't find tracklog stop. Closed, restart and tracklog home. The 15k walk just had the default title & no track or segment. The tracklog home has the walk prepended to the journey home. Saturday with B56 Started walk as usual. At the end at screen on just a white screen with the correct track. B56 then freezes. After problems restarting track has been correctly recorded. Ted
A fully successful track today . Pause, resume and all. Roger
Login to post a comment