Start a new topic

iOS Beta 1.10

Hi chaps,


Statistics

==========


Stats basic function: Tap on the button top left to open stats. Swipe left to close, or swipe down to expand. Double tap on a cell to get the list of options.


Stats now has the following options:


Accuracy - Reports GPS accuracy.

Altitude - GPS altitude

Direction - Direction of travel

Distance - length of current tracklog. Currently this does NOT also add on the distance from the last trackpoint in the tracklog to the current GPS location. This is on my list to get altered. So distance will only update as each trackpoint is added to the track currently.

GPS Reference - the location reported by the GPS

Speed - speed reported by the GPS

Time - hoping I don't need to explain this one.

Vertical Accuracy - again reported by the GPS.



I think there is still some finessing required. Turn off the GPS, things don't blank currently. I also believe there is some 'stacking' up of data, in that if you stop walking, it takes a few seconds for speed to drop to zero. I think we aren't processing data as fast as its coming in, so we probably just need to drop some values.


Overall though this is taking shape now, and the updates to the screen now feel smooth. The interface needs some fine tuning, and then we have some options to add.


On Tracklogs, the Pause/Resume bug reported by Tony has been fixed. I've not looked at the metres/distance bug that was reported, although that might have been fixed by other changes made for Android.


Enjoy,


Graham


Hi Graham, Quick look this morning, installed almost instantly. Using just the internal network location the app responds very quickly, reporting accurate location, I selected a number of menu displays all worked as expected, looking very good and so much better and more stable than the Android version. Ernie
1st test in a while. I was able to populate the stats boxes and put them away again, but the map stopped responding to movement (drag or pinch). It seems to be triggered by opening the main menu and going into settings whilst the full stats window is open.
Stats look good but I seem to have lost map scrolling,pinch to zoom and start track. In short any map screen actions. Menus & maps seem ok. Tim

Hi Tim, if you kill and restart can you confirm that the map functions are working from the get go? Then try the main menu -> settings whilst you have the full stats on display. That triggers it for me.


Tobes

Slightly bizarre . I had closed it down for about 30 mins. When I reopened it was all working fine, no matter what menus & selections I made. Tim

Hi Graham,


1.10 installed fine and the stats settings worked as described. I think the direction is only good when in portrait - needs a landscape compensation. Are you planning to add battery level?


The tracklog interval setting does now seem to behave but tracking is now even more problematic. 


I started a tracklog, closed the lid and on reopening OMN had gone from the foreground (it had not quit but, on opening the lid,  the Home screen was displayed not the map). Open OMN by either tapping icon or the app switcher and OMN appears to reload as suggested by the sign on screen and a pause before the map is displayed. The track was there but no tracking had taken place when the lid was closed plus a spurious point was plotted. The attached screen shot shows the spurious points and the wp free straight lines during the periods of lid closure. With these issues there was little point in checking pause/resume.


Tony

IMG2224.png
(1.34 MB)

@Ernie – Android has been so frustrating, and to think that so much of this code is shared between the two….


@Toby / @Tim – I’ve seen this once, but I can’t replicate it continually. Have either of you found a reliable way to reproduce this? I’m sat playing with it now, and I can’t make it happen.


@Tony – direction will need adjusting for orientation. I’ve popped that on my list. More options will come once we get this all stable. My initial aim is to get it stable and released, then once we have a workable system, adding new options is then certainly on the list such as battery level, and quite a few more.


The spurious point is odd. I will investigate.

 

Thanks chaps,

 

Graham

Fairly reliably. 


Open OMN

open the stats slide

full open to the stats "pane"

tap on menu icon - open settings

close settings

turn on gps

close stats panel to stats ribbon

reopen to full pane

menu settings done

close stats panel

close stats ribbon

try and move map...

@Toby - many thanks. I can reproduce that.  Now to work out why!

Admittedly I had toby’s Instructions opened on the same screen as omn but I can not reproduce the problem at all. Was begining to think I had imagined it. Tim

I downloaded and installed 1.10 beta on my iPhone 6s. Seemingly no problems. 


On Sunday I went for a bike ride using the tracking facility. I was also using a couple of other tracking apps - which worked fine.


The track I produced with OMN was partial and had a spurious point. If I import the track into the  non-beta version of OMN it crashes - both on Mac and iPhone. I have exported the track and examined the xlm file - the spurious point appears to be (0,0). I'm sorry but I've lost the xml - I can recreate if need be when I'm back home later in the week,

Hi Graham,

Just had a very unusual experience with OMN B1.10.Went for a walk today and used iphone,ios 11.1.2, 1:50k maps downloaded. I switched on GPS and started walking. At some point I opened the phone to check where we were and map was a chequerboard of map tiles and white tiles and OMN was well and truly hung. Had to restart OMN and try again. Again GPS switched on  and kept checking location. At some point it happened again. Battery %age plummetted, suspect that omn was looping. Started at 100%, after 2 hours I was at 6% and OMN was by far the highest cpu user. 

I didn't have a tracklog running. 

Dennis


@Roger - it seems like a little gremlin has sneaked in regarding (0,0). Its on my list to investigate.


@Dennis - strange, but I might know why....   I think on low memory warning, we now chuck out some tiles, I'm wondering if we ended up in a loop of throwing out tiles, and reloading them, triggering the low memory, and around we went!  Which iPhone are you running please? In the past, have you had the low memory warning? I presume you were on 50k maps, and were you zoomed out a little way?


Thanks chaps,


Graham

Phone is iphone 6 model MG4F2B/A 64GB and yes 50K maps zoomed out a little. In the early days I may have had low memory warnings but since you started discarding cached tiles I haven't had low memory.

I did have a lot of apps loaded at the same time so your explanation is plausible.

Login to post a comment