Start a new topic

OMN PC Beta 1.0.29

Hi all,

 

This beta includes some under-the-hood improvements to streaming, map download and verification of maps.


We have had some reports of issues on the PC, but the main issues reported have been on Android and on macOS. However, with the majority of our code being shared between the four platforms, we have restructured the core code, and the PC is getting its beta first.


Numerous things have been resolved:


· In some cases, map download/verify and map streaming were interfering with each other, and would get in a loop eating up the processor time and making the whole system grind to a halt.

· Map downloads and Map streaming were updating the screen on each map tile downloaded, regardless if it was on screen or not. Streamed map tiles still update the screen, but for map download/verification, we update the in-memory tile cache just on the completion of the verification/download of a complete map.

· Reduced some complexity in the draw routines. Logically it is now doing less, and I *believe* its slightly quicker, but to be honest, on a quick laptop, I’m not sure if I’m just imagining it. Slower machines, and the mobiles may well show this up.

· Quite a lot of other improvements to general logic of the map handling process in memory.

 

Sorry its not very exciting, but hopefully it adds a further level of robustness to the system.

 

It should auto-update, or you can download from here:

https://rink.hockeyapp.net/apps/b781e300ff16447a868c8d8e78045d27

 

Graham

 

 


It looks like Height data isn't streaming correctly. You can download it from inside the My Maps as normal, and I will get this fixed for the next beta.


I've just downloaded the latest Beta to carry on testing, but I've had to change computers (as my old one died!), but when I try to load my maps in order to test functionality I just get a message saying "No valid subscription.

Maps can only be downloaded if they were purchased within the last 30 days, or you have either an OS Premium Plus or Standard Plus level subscription..........."


Does this mean I can no longer test with the Beta?

Hi Graham,

Auto-updated to Beta 1.0.29.0 without any problems.

Verify
I remember you mentioning that, provided no updating was required, it should be possible
to Verify without an internet connection. I've tried to Verfiy the GroundRanger map data but
it doesn't seem to be doing much. The first map (Central England) is showing as "Verifying"
and all the other GroundRanger maps are showing as "Pending Verify".  The Central England
map verify counter showed "0/1228 - 0%"  for about three minutes then changed to "1/1228 - 0%",
where it has been stuck for that past 30 minutes. Either "no internet" Verifying is broken or Beta
1.0.29 is waiting for an internet connection. If the latter, then a suitable warning message is
required when there is no internet connection.  Task Manager shows OMNB using between
3% and 4% CPU. Concurrently, Windows Modules Installer Worker is using between 20%
and 30% CPU.


Regards,
Paul Whitfield

 

Graham


Verify - MUCH better.


Last week I verified my 25KHD maps for the whole country on production 1.0.28 which took several hours.  My map files are shared by both the beta and production system.


On beta 1.0.28 I ran a verify against the SU area of the 25KHD map.  CPU load was 65%, there was no significant network traffic (as expected).  After 1 minute only 377 out of the 1600 tiles had been verified.


I allowed the auto upgrade to go to 1.0.29.

I ran verify against the same SU area and couldn't see my watch quickly enough before it had finished.  I then ran verify for the whole country for the 25KHD.  CPU load was approx 75% and again no significant network traffic BUT the whole country was finished in 45 seconds!!


I had not previously verified the 25KSD maps to pick up the 1st December updates.  I ran verify on 1.0.29 for the whole country and this also finished quickly - perhaps a minute.  There were a few instances of significant network load (circa 10Mbps) as new map tiles were brought down.


Lastly I ran verify for both the 50KSD and 50KHD maps.   I did not observe any network traffic for either which was a surprise as I thought my 50KSD was using the September update whilst the 50KHD was updated last week to the December release.

The complete country took about 45 seconds for SD and 75 seconds for HD.  CPU load was again around 75%.  I did notice that the verify counter for each map stalled at "0/xxxx" for about 3 seconds before rattling through each of the tiles and moving to the next map.  Is that operating in the way that you expect?


I hope that others also see this as a major improvement - I can't wait for the Android implementation!


David


Hi Graham,

 Verify
Continuing the same GroundRanger test in my previous post, there was no progress after five
hours. I opened an internet connection but still no progress. Cancelled the Verify and started
again. After about 15-20 seconds, the verify counter started incrementing and the verify process
completed for all the GroundRanger map areas. The verify process took 1 hour 14 minutes to
complete. For each map area, the verify process took 7-8 minutes. For each map area, Task
Manager indicated no network activity whatsoever, CPU utilisation ~4%, Disk activity 0.3 to
1.5 MBytes/s.

CPU utilisation
After starting Beta 1.0.29, there is a constant background CPU utilisation of ~3%.

Regards,
Paul Whitfield

 

Graham


Following on from Paul's GroundRanger experience.  I ran verify against my whole country GroundRanger maps - it took about a minute to complete. There were a few seconds at the start where the first map area counter stuck at "0/xxxx" but as soon as this started to increment I did not see any subsequent stalls on any of the other map areas.  My maps are on an SSD drive and they had all been verified previously in the summer.


I noticed after the verify that Task Manager is reporting a continuous 20% GPU utilisation whilst OMNB 1.0.29 is running even though the map is not currently displayed.  I stopped OMNB and ran production OMN 1.0.28 and the GPU utilisation reported in task manager is 2%.


The GPU load on 1.0.29 seems to build up after 30 seconds to a minute of the program being in the background.


David

Hi Graham,

Verify
With internet access disabled, I re-ran the Verify on the GroundRanger maps (whole of UK)
and it took 10 seconds in total to complete.

I don't understand why the earlier verify took 1hr 14min or why the verify required an internet
connection - Task Manager showed no network activity at all; though there was a lot of disk
activity. As well as Beta 1.0.29, I have OMNC, OMN 2017 Release and Anquet v6 installed
on the PC. Could it be that map data is being updated internally (between OMN versions)
rather than over the internet. If so, then why did the verify not work without the internet.

Regards,
Paul Whitfield

 

Hi chaps,


Well this looks promising.


@Andy – sorry. If, you have a decent set of maps, you most likely now want a Standard Subscription, or if you want new OS mapping, then one of the Premium Subscriptions.


@Paul – I will take a look at the internet connectivity. I will probably just disable it if there is no internet, after all, it can’t do anything. The second verify, the times make some sense depending on how much needed updating, but I’m not sure why you saw no internet activity – you don’t have a USB stick or something plugged in that it was copying data from? If you run it again now with internet, does it run through quickly? It should if the data is now all up-to-date. Have a poke around and see if any timestamps are for yesterday for the GroundRanger map packages.


@David – thank-you. So, the verify of the 25kHD you have already verified last week would have hopefully not brought down any new data. The CPU usage will be it refreshing the in-memory cache at the end of each map, and as 25kHD is broken into 50+ maps, it will have been run 50 times. I can live with that, given the time it’s taken.


25kSD came down very quickly then. I would think it most likely had about 600mb or so to download. 50kHD should be fine as you say, but 50k SD perplexes a little. It won’t have been that much data though, full set is about 3.5gb, so circa 300 mbs, still that should have shown itself.


Like Paul, would you mind having a quick look in the GroundRanger directory – hopefully some pkgs have yesterdays time stamp on, showing they were downloaded yesterday.


Thanks for the pointer on the GPU – I know where that has come from and will get it resolved. Android is thankfully coming together nicely at the moment. That’s been a hard slog, but I’m seeing some nice results here in testing at the moment.


Thanks chaps,

 

Graham

 

 

 

 

Graham


I have looked at the groundranger directory.  All of the pkg files that I have seen have last modified date of 13/10/2017.  However the gba.gbaz have a datestamp of the 13/12/2017.


I have also had a glance at the OS25K pkgs and I can't see any that have a time stamp after the 13/10/2017.


Could you please give me the names of a few pkg files that were changed in the December 2017 refresh and I will explicitly check those.


David

Hi David,


I just logged into your account, and downloaded OS 25k SU from an old USB drive I have with me.


This file

"C:\\ProgramData\\Outdoor Map Navigator\\pkgs\\os125000\\1\\1\\5\\445\\445_185.pkg" was 647kb (not sure what date this actually comes from without doing some searching.)

After verifying it is now 657kb in its updated form.


Did you do a Sync in My Maps before doing the Verify to update your local map definitions?


The image below, you can see the older data is at 19.49. New data is 19.56 (I had the system paused), and then 19.59 once I let it continue.


Are you seeing similar details?


Graham


image


The time stamps aren't used by the system, it just shows when OMN wrote the data. File size is important.

Hi Graham,

Verify
Looking through the GroundRanger map data, the timestamps of all but a handful
of files, for the directories that I looked in, are dated 13/12/2017. So the map data
has clearly been updated. I find it very strange that Task Manager did not show any
network activity for Beta 1.0.29 during the verify.

The Beta 1.0.29 map data is under directory

  D:\ProgramData\Outdoor Map Navigator\0005816281208040000000\pkgs

There was no external disk/memory stick plugged in during the verify.

I've run the verify again and it took 15 seconds to complete, both with and without internet
connectivity.

Regards,
Paul Whitfield

 

Hi Graham,

I wasn't seeing network activity in Task Manager because of an issue with the
Ethernet adapter in my PC. I've found a fix for this and run some test map data
downloads and network activity is now being properly reported in Task Manager. 
The Verify tests now make sense.

You mentioned that you were you were thinking of disabling Verify if there were
no internet. Are there not some instances where a Verify without internet might
be useful, e.g. you don't want to download the latest map data but just want to
show that there isn't an issue with a map package? You might have limited or
no bandwidth resource, e.g. when on holiday.

Regards,
Paul Whitfield

 

@Paul - sounds like it was doing the correct things then. I don't think verify is any use without the internet - re-index is, which is in Settings. Verify basically checks to see if a pkg is up to date, and downloads it if not. If its not up-to-date, it doesn't tell you, it doesn't correct anything, and with no internet it can't do anything.  I've disabled it in the next beta. Re-index doesn't need the internet to work.

Login to post a comment