Start a new topic

OMN PC Beta 1.0.31

Hi all,


Building on 1.0.29/30,


Sorry for so many betas so close together. I believe this is the one that will now progress through to a live release unless it hits issues.


This beta contains further under-the-hood changes to facilitate better map handling on the mobiles.


It should auto-update, or you can download from here:

https://rink.hockeyapp.net/apps/b781e300ff16447a868c8d8e78045d27

 

 

Many thanks,

 

Graham


Graham Installed 1.0.31 without problems. Entire GroundRanger downloaded steadily without problems with each map taking about 10-12 minutes. I also tried downloading from the full monty usb stick. GroundRanger central England took 13 seconds and the entire 1:25000 HD map took 17 minutes. Looking forward to the android release. Mike

Thanks Mike.


Graham

Graham


Working with 1.0.31 production release I have had a number of a "process stopped working errors" from OMN2.  Clicking through the errors and / or restarting OMN2 I completed what I needed to do.  Hopefully the crash reports will get to you. 


I was working with a file of 530 waypoints created by GPSBabel.  At the time I had several spreadsheets open including a large one of approx 50mbytes on disk.  The spreadsheets were not to my knowledge performing any calculations.


I used GE to load the file of waypoints.  On several occasions the PC fans kicked in - indicating to me that a lot of processing or GPU cycles were being consumed.


If you need I can try to recreate the environment in which I was working and get a better record of precisely what I was doing that triggered the crashes.


David

Morning David,


We have a lot of code changes coming to the PC in the next beta - quite a lot of it efficiency code from Android changes, so I think we need to wait for that for now.


Many thanks,


Graham

Graham.


OMN 1.0.31 production.


Small irritation with the Find Screen.  If you type something into the Search box and then press the radio button for Road name or postcode the search uses the typed in value.  However if you press the Grid Reference radio button the search box is emptied and you have to retype the grid reference.


David

I've just had to revert back to OMNC PC. I had a track where I had omitted to reset the device at the start of the walk. So I had to use split route on the old software to recover the relevant part. It doesn't get daily use, but I find the lack of split a retrograde step in Beta. Ted

@David - thanks.

@Ted - we have a number of smallish functions still to implement, and Split Route is on the list.


Thanks chaps,


Graham

Hi Graham

I've set myself up with a Windows 8.1 VM running on a mac. The win 8.1 is fully up to date and performance on this mac is pretty good.

Having been using it for a few days I installed the PC OMN from the web site. This is the first time on this VM so first thing I got hit by was .net 4.6.1. Installed that and it started, checked my account, sync/d maps and started to sync icons and got a popup saying "stopped working". Tried a few more times but got the same.

Tried downloading latest PC beta from this forum and it has just done the same to me. 

Didn't quite get as far as showing the map but the icons top left are there.

I suspect it is somethingto do with my account but is there a known solution? Signature for crash below..


Like the splash screen and the icons, mac don't have these yet but ought to...

Dennis


Problem signature:

  Problem Event Name: CLR20r3

  Problem Signature 01: OMN2.exe

  Problem Signature 02: 1.0.31.0

  Problem Signature 03: 5a33f319

  Problem Signature 04: Microsoft.HockeyApp.Core45

  Problem Signature 05: 4.1.6.1005

  Problem Signature 06: 5887f512

  Problem Signature 07: 61

  Problem Signature 08: 0

  Problem Signature 09: System.NullReferenceException

  OS Version: 6.3.9600.2.0.0.768.101

  Locale ID: 2057

  Additional Information 1: 466e

  Additional Information 2: 466e1b55d3693645c1ecce56ea324084

  Additional Information 3: 68ef

  Additional Information 4: 68ef59f44ee7407e41af89c7ef8350e2


Found this report my system relating to the above

wer
(17.9 KB)
It would help if the PC print options, particularly grid & numbers were saved from one print to the next. The numbers & grid lines are a big improvement over the BL & TR of previous versions. But out of context just numbers really need the 100k square letters somehow. How one would cope with the map centre being the NE corner of say SK I'm not sure! Ted

@Dennis - you have got further than I have with a VM. I've never managed to get OMN running in a PC VM running on top of macOS. Monogame wants DirectX, which wants direct metal,which is no doubt sent through some other libraries above macOS, and frankly it all seems to be a bridge too far. I normally get a through sync, but never see the map.  Stability issues inside a VM don't surprise me. Which emulator are you using out of interest?


@Ted - Agreed the settings could be held between sessions. The printer header already deals with letters - I've just put a quick article together about it: https://support.anquet.com/solution/articles/13000043745-printing-grid-numbering





I use VMware Fusion. I did notice that my version is no longer supported (lost support Dec 2017) and it is version 7 (latest is 10). Every thing I have tried so far is able to run, with the exception of OMN. Like you I get up to the map..

Since you try out new features on PC first I thought I'd try to run a copy to see. What I have seen so far seems a bit more professional than Mac. 

As I said I prefer the icons for GPX manager, editor, the slider for zoom, the splash screen.. looks more polished than 4 lines of grey at the top of the screen.

Dennis

I presume the header is in v1.0.32 to be released. Because there is no header on yesterday's print with v1.0.31. Ted

Graham,

VMware does support DirectX so there shouldn't be anything to prevent OMN running on a VM. From the report I sent can you see in which piece of code/function call/library call OMN has crashed? Might be a config change/small bugette.

I did increase the amount of shared graphics memory to 2GB and this VM supports DirectX 9.0EX with Aero and OpenGL 2.1

Dennis

Login to post a comment