Start a new topic

Android Beta 64

Hi all,



Lots more fixes and improvements.


  • ‘Not Downloaded’ tile showing up on load-up – fixed.
  • Start-up – I’ve made a lot of changes cleaning up the logic in core code. @Ted, your account opens up on my Nexus 6p from closed, to viewing map in under 10 seconds. I will be interested to hear what you find. *** I've just tried the release build (which runs quicker than internal debug builds, and on my account, nothing to map takes approx 5 seconds.)
  • Settings->Reset->Styles – either Line or Waypoint wasn’t working correctly – I’ve resolved this. Similar fix applied to Settings->Reset->Icons
  • On tapping ‘Save and Close All’ in GE, we now return to the map.
  • If you do a Settings->Reset, you will now see we have a default set of stats in the stats bar, so new users aren’t faced with blank tiles. You can of course still set them up as you require.
  • GPS Reference has been renamed to Grid Reference
  • On Find Place, the second row of data is now Town/Country rather than a grid reference.
  • In GE, if you select a waypoint in a route/track, long press and hit delete, the waypoint now gets deleted. (It was wrongly deleting the route/track it was part of.)


 


What am I currently working on:


  • I’m trying to get a plan together for the compass, so that its an addition to users post go-live, rather than a massive upheaval of the interface. – see: https://support.anquet.com/discussions/topics/13000019189
  • White tile issue I have tracked to Android asking us for memory, and we are over zealously clearing the cache. What I am seeing is a tap on the screen forces a redraw, and all is ok, but this needs fixing.
  • I’m building some logic into the core code, that after 3 failed startup attempts, it will offer to do a reset, hence meaning no need to uninstall/reinstall which may well uninstall your maps.
  • Still a small list of other bugs outstanding.



You can download from:


HockeyApp: https://rink.hockeyapp.net/apps/b3133bdf93e04a62bcfc1612fccdec23


Google Play: https://play.google.com/apps/testing/com.anquet.omn2



** this takes a little while to come out. HockeyApp email notifications will come out once the build completes.



Graham


Had a very quick look, seems quicker on start up. Everything seems Ok but havent done ant tracklogs. Stats "grid reference" is not populating.
Start up: Google play Phone blue screen 2secs white screen @64secs Tablet blue screen 3secs white screen @124secs Hockey Phone blue screen 2secs white screen @7secs Quite a different. On install both went to feedback which was sent 1st time. After feedback map appears. Stop /start press wait then goes to map. It now goes straight to map with the Google play timings above. I then installed the Hockey version and the timings are very acceptable. The Hockey installation is fresh, so there will be no local maps. Is this an issue? I remember a new OMNC is quick, but the progress bar gets slower as the map library builds up? Thanks Ted
I have just loaded 64. I haven’t been keeping track of your progress, apologies if you are already  aware or dealing with the fact that verify is still causing me issues – it stops  on 99% on several  50k maps areas. In the past a sync seems to clear the 99% which then shows  as  installed.  The good news is that the speed continues to be very good until it reaches 99. I don't know if I have the latest version of map installed, how do I check this?

George

 

@Ian - many thanks, I will get that one fixed on Grid Reference.


@Ted - nothing should slow it down - the amount of maps shouldn't matter. Can you open up your phone, Settings->Reset, and then re-open and it will do the slow sync. Then try stop/restart and let me know how that goes please? I think your local database is still 'large' due to the sync bugs we have now fixed. A reset will hopefully clear this away.


@George - I think I know the issue here. Can you please do a Settings->Reset, and then the long sync on restart. Follow that with a Settings->Re-index to make sure everything is indexed properly. That should get you to a stable state. If you have maps which are then Partial instead of Installed, the please hit download on them. I think you have missing tile data for some enhanced zoom levels, which we were in earlier betas incorrectly not spotting - we therefore claimed the map was installed, when not all the data was in fact on disk, and then verify would not get to 100%.


Thanks chaps,


Graham

"GPS Reference has been renamed to Grid Reference" stats shows "grid location"
Hi Graham. Thanks, both devices are now starting up correctly. Thanks Ted

Graham


Its looking better.


Start up is only a few seconds but I find a completely blue or completely white screen disconcerting.  I think you will need to have some form of progress bar visible.                      



By aggressively scrolling and zooming maps (all held locally) sometimes I see the white tile issue.  However a tap on the map does not repopulate it for me.  If I move the map it is then fully populated.            


I no longer have the duplicated styles with all the numerics appended to the names.                 


I did a find place for "Well" (A small local village).  Over 200 results were provided of which the majority were "wellxxxxx".  The 4 "Well"s in the country were listed first.  I tried to search on "Well " (nb space) but this also returned over 200 places.  Any thoughts?    


David

Hi Graham,

Installed Beta 0.64 over Beta 0.63 via hockeyapp without any
problems.

Start up
Takes 9-10 seconds in total.  Approx. 4 seconds blue screen followed by white screen
then map.

GPS Reference
The new naming for GPS Reference shows as "Grid Location", not "Grid Reference",
and remains empty even with GPS on and a GPS icon with status green.

GE - "Save and Close All"
Could this be extended to the case where you close a GPX file that is the
only GPX file open?

Regards,
Paul Whitfield

 

I too have been thinking of the multiple search places problem. OMNC had a sort by distance from map centre. It doesn't always help but very often you are looking for somewhere not that far away. You could always, say, centre the map on Keswick in a two stage search. Ted
When using Find, I select an item the map quickly flashes the place found then reverts to the point where the map was before the find. I have the GPS turned on and centred. If I turn the GPS off the map displays the new location correctly. If I turn the GPS on and move it off centre I get the part drawn amp of the new location with a load of "downloading" white tiles that don't download, (at least after 20 seconds). Also postcode search is much much slower than the place search.

Hi Graham,


Installed from Google with no problems


Start up time good - 5 secs to full population of screen using 1:25 HD map


Performance is definitely better for me, with my 21,000 gpx now only taking 10 seconds to open.


Minor Glitchs


I was testing applying styles to track logs on ver 63 this morning, then I noticed that 64 was up so have switched to that.


Same problem on 64- If you define a new line style on PC and sync devices, the new line style does not appear on phone until you have shut the app and re-opened.


While testing the styles I went into Edit mode ( I now realise you don't have to!) and there is still no way that I can see to back out of inadvertent alterations to a route. 


The "Close without Saving Changes" option still needs implementing I feel, (or an Undo option)

Small request :-)

Would it be possible to add check boxes similar to the PC version of GE, so that you can choose to show only one route at a time when you have a gpx with multiple routes?

This is useful on the PC.


Coming along nicely now


thanks

Regads

Paul


Having done several  Settings->Reset lately, I have noticed that the information on the Settings->Reset states that whilst the route data will be deleted, the map data will remain. What is does not mention that the location ofnthe map data is changed from the existing location to 'Internal'. This could lead people to think that the map data has been removed when what is needed is a Settings->Data->Target,.

Mike

 

 

Grahm,

Following on from what Mike says I did a reset yesterday, as you advised,  and forgot that it would default to ‘Internal’.  When I downloaded maps again all available space was consumed which also  corrupted my OS.  A factory reset and numerous hours later I’ve almost restored the phone to where it was.  Obvious point, can you add a simple check where by if a requested download is too big for space available.  it won’t try, or at least warns of troubles ahead!   To add insult to injury I am still experiencing the same problem I was trying to resolve, namely maps sticking on 99%. Nothing I’ve  tried since rebuild  will  work – some  maps are still showing 99% . I have headers in my map manager for OS 1:50,000 HD and  GB 50K HD Subscription. When I downloaded the later  the first one is also showing activity, which I don’t expect.  I don’t think  duplicate downloads are occurring.

George

Yes, MyMaps has some legacy issues. Some bits of the country for me have : 1. Individual sheets of various series or Cut Your Own. 2. Whole country. 3. GB Subscription. I tend to now only use the GB Subscription for download but have to scroll through the others, which are also updated. It seems a bit of tidying up is in order. Not sure how because presumably if a subscription lapsed it would fall back to the older purchases. Ted
Login to post a comment