Start a new topic

Android Beta 64

Hi all,



Lots more fixes and improvements.


  • ‘Not Downloaded’ tile showing up on load-up – fixed.
  • Start-up – I’ve made a lot of changes cleaning up the logic in core code. @Ted, your account opens up on my Nexus 6p from closed, to viewing map in under 10 seconds. I will be interested to hear what you find. *** I've just tried the release build (which runs quicker than internal debug builds, and on my account, nothing to map takes approx 5 seconds.)
  • Settings->Reset->Styles – either Line or Waypoint wasn’t working correctly – I’ve resolved this. Similar fix applied to Settings->Reset->Icons
  • On tapping ‘Save and Close All’ in GE, we now return to the map.
  • If you do a Settings->Reset, you will now see we have a default set of stats in the stats bar, so new users aren’t faced with blank tiles. You can of course still set them up as you require.
  • GPS Reference has been renamed to Grid Reference
  • On Find Place, the second row of data is now Town/Country rather than a grid reference.
  • In GE, if you select a waypoint in a route/track, long press and hit delete, the waypoint now gets deleted. (It was wrongly deleting the route/track it was part of.)


 


What am I currently working on:


  • I’m trying to get a plan together for the compass, so that its an addition to users post go-live, rather than a massive upheaval of the interface. – see: https://support.anquet.com/discussions/topics/13000019189
  • White tile issue I have tracked to Android asking us for memory, and we are over zealously clearing the cache. What I am seeing is a tap on the screen forces a redraw, and all is ok, but this needs fixing.
  • I’m building some logic into the core code, that after 3 failed startup attempts, it will offer to do a reset, hence meaning no need to uninstall/reinstall which may well uninstall your maps.
  • Still a small list of other bugs outstanding.



You can download from:


HockeyApp: https://rink.hockeyapp.net/apps/b3133bdf93e04a62bcfc1612fccdec23


Google Play: https://play.google.com/apps/testing/com.anquet.omn2



** this takes a little while to come out. HockeyApp email notifications will come out once the build completes.



Graham


Hi, Just joined the Beta program with this version.

Is there a master list of known issues anywhere ?

Dont want to raise issues which are already known about !


I used this version on a long walk yesterday, and it was certainly an improvement. The white screen issue on opening the app is disconcerting - but I see you are aware of that.
I agree with the others on the issue of a reset changing the map location.
The two things I miss from the classic version are the directional arrow and average speed in statistics.
Does make you realize how solid and reliable the OMN classic app is!

 

A little help from anyone on the forum. In the Android app is there anyway to change the style of a track that has been recorded on my phone? I'm guessing that the Styles/Icons menu option in Settings if for future tracks/routes.

Hi Ian,


Open the track and hold your finger on the track until you get a pop up menu.


To style entire track, choose > Style>Route Line Segment.

You need to have defined your required style first in the Settings>Manager menu, 


1 person likes this
Hi Graham, Downloaded and installed over 0.63 without any issues. Initial delay in opening but now opens almost instantly. GPS location works well and a quick tracklog seems to be working OK. Ernie
Hi, can stats bar state persist between sessions? It opens up every time I start OMN. Thanks

A minor inconvenience is that when I start the app. after the blue screen with the title, I get a complete white screen, then the map, but with the equivalent of the title bar in plain grey. - this persists until the left hand menu icon is pressed - the left hand menu icon only seems to act as a toggle replacing the top line of tiles with grey or with the map - does the left hand menu icon have any purpose?

Is there a way in the Android OMN to move to a distant place easily? I often use my phone to look at places far away.  The only way I can easily do this is to switch to showing the GB road map, move the current position to where I want to examine and then return to the 1:50,000.  I would have thought that the "Find" menu ought to allow one to go to the position found - but it doesn't seem to.
Am I missing something?

 

Peter, how far is your distant place? I guess a piece of string.


I use a combination of

  • zoom right out on the current map, pan then zoom in (on my phone I can zoom out and have c.50miles (diagonal line)
  • find a place (eg town/street) 
  • change map type like you describe
  • occasionally (very) I'll create a waypoint then go to it via the GPX editor (but that is a lot of clicks).
Thanks

Peter, Find does allow you to go directly to the place. Type in a place name, in the list shorts press/click on the correct place, (NOT the INFO button to the right), and the map should display the map at that place.

PaulQ, Thanks, that worked......

Hi chaps,


Let’s start with the good news. Things are looking nicely stable. Still some crashes, but crash reports into Google are now much lower. Also, the majority of the comments on this thread now appear to be niggles and much smaller issues.

 

STARTUP

A while ago, I had a spate of people who couldn’t start-up. We have reached out to those who have contacted us, but I currently have had very little feedback, and frankly I have no non-startup cases to investigate.

If anyone is still having issues, or if you have an older phone/tablet you can test on, that would be much appreciated.

 

The Blue screen / white screen / map is now being updated to show some graphics whilst it goes through the start-up process.

 

@Steve – you will have to remove the old selection. However, the new one isn’t currently populating. I’ve popped persisting the stats bar settings between sessions on the list.


@Ted – excellent. Thanks.


@David / @Ted – we will have to come back to find at some point for some refinement. The most likely option will be sort by distance.


@Paul – thanks.


@Ian – I think we need to turn GPS to ‘off-centred’ on a Find action. What is currently happening is you go to a location, but on the next GPS fix, it re-centres on the GPS.


@PaulQ – I’ve logged the Styles bug. Close without saving changes is on my list. Undo we will need, but that’s a bigger task. I’m not sure about the check-boxes – technically behind the scenes its easy work, but the question is how to not over-complicate the mobile UI.


@Mike – it’s a fair point, and one that has obviously caught George. The idea of Reset is that you don’t need to uninstall the software, and it takes us back to a factory setup, which is internal for storage. As soon as I try to re-connect, this is where things will blow up in a different direction – SD card renamed, or gone. I will have a think on this one.


@George – it’s a lot more complex that you might think. Firstly, we don’t queue everything at once, so when you hit download on map 3, the fact 1 & 2 are already queued, I would need to calculate how far they have got etc – it can all be done, I just don’t think it justifies the development time right now. If we just allowed individual map downloads, and froze the interface until it was downloaded, it would be much simpler, but that would remove the abilities OMN has. On top of that, whilst the downloads are running, you can have Amazon downloading videos, and we will hit the limit anyway. Some work however is needed in this area in due course. However, the 99% issue we do need to resolve - Can you give me the name of one map and the product that it is in which is failing, and I will try your account. I can’t currently reproduce your findings on my account.


@Ted - I have now altered the code, which will be in the next beta, so that if you have say 50k subscription maps, no other 50k maps will show up in the map list. This is done in code, so therefore nothing is removed from the users account, so if the subscription lapses, the other maps would show up again.


@Rob – welcome. There is currently no master public list. I try to catalogue everything that comes through the forum, but I then triage that as we have development time, and generally prioritise around bugs/feedback here/feedback to the support desk.


@Peter Oliver – OMNC is still a good little app. Compass works are taking shape - https://support.anquet.com/discussions/topics/13000019189 We certainly have more data fields to add to the statistics interface now it’s shaping up.


@Peter King – if you double tap on the grey bar at the top, you can set different data to view. You obviously installed a beta a little while ago before we put default settings in there. A new install now puts some default settings into place.

 

We are making good progress towards the next beta.

 

Thanks chaps,

 

Graham

 

 

 

 

Graham,

 

The day after last feedback I noticed all maps were showing ‘Installed’. I’ve just kicked off a new verify: Central England & Central  Scotland changed to installed after a few minutes, however Eastern England  now showing Verifying (5113/5116) – 99%, North East Scotland Verifying (6478/6480) – 99%, North West Scotland Verifying (6770/6772) – 99% -  Northern England  verifying (5834/5836) 99%  Scotish Lowlands & boarders  Verifying (5479/5496) – 99%  other still running. 

Regards

George

@George, thanks for the quick feedback. Can we please move this to a new thread as I think there will be some back and forth whilst we resolve this. I started this thread: https://support.anquet.com/discussions/topics/13000019246

Login to post a comment